Mailinglist Archive: opensuse-de (1522 mails)

< Previous Next >
Re: Problem beim booten
  • From: Ulrich <Zarathustra@xxxxxxxxx>
  • Date: Sat, 8 Apr 2006 13:28:00 +0200
  • Message-id: <200604081328.01606.Zarathustra@xxxxxxxxx>
Also schrieb Michael Weyers am Samstag, 8. April 2006 12:57:
>
> Na ja, dass Problem ist nur, dass es nicht an der menu.lst nicht liegt,
> die wird nach dem "anschieben" durch die CD ordungsgemäss ausgeführt
> und lädt mir entweder XP oder Suse.

Wenn du mit der Installations-CD bootest, dann werden nicht die Konfigdateien
von Grub gelesen. Das Programm auf der CD ermittelt die richtige
Konfiguration. Auch der Kernel wird so von der CD geladen. Nur 'init' und
alles was danach kommt, stammt von deiner Installation auf der Festplatte.

> Da die menu.lst über die Platte
> nicht geladen wird, scheint es meiner Vermutung nach an dem MBR zu
> liegen, der vielleicht irgendwann mal falsch geschrieben wurde. Yast
> soll in diesen Dingen ja nicht immer sehr zuverlässig sein.....

Des MBRs wegen meine ich auch du solltest in Yast (nachdem du gebootest hast
mit Hilfe der CD) ruhig mal die Floppy auswählen als Ort des Bootloaders.
Damit wird der MBR auf der Festplatte belassen, und bloß einer extra auf die
Floppy geschrieben (oder soviel Floppies wie du magst). Falls du dann booten
kannst, liegt das Problem wohl irgendwie an den MBR, da Grub auf dem Floppy
die menu.lst von der Festplatte benutzt.
Wenn der MBR auf der Festplatte wieder funktioniert, dann kannst du
wahlweise von Festplatte wie auch von Floppy booten.
Ob Yast nicht immer zuverlässig ist, kann ich nicht sagen. Bei mir hat Yast
wenigstens immer getan was es tun sollte.

Bei 'Konfiguration des Bootloaders' (in Yast) kannst du wählen ob der Code im
MBR ersetzt werden soll. Sag mal 'Ja' zu dieser Frage.

> Gibt es eine Möglichkeit, sich den entsprechen MBR zu "saugen" und ihn
> dann auf Platte zu schreiben? Vielleicht kennt sich jemand damit aus???

Das MBR ist, soviel ich weiss, ziemlich systemspezifisch.

> Wird bei einer Neuinstallation von Linux das Problem behoben sein,
> falls man das überhaupt vorher sagen kann?

Weil Grub gerade nicht funktioniert willst Du noch keine Neuinstallation
vornehmen.

Ich habe solche Probleme auch so hin und wieder. Ich spiele dann was mit den
verschiedenen (Yast-)Optionen herum. Habe auch schon mal LiLo (Bootloader wie
Grub, nur gerade ein wenig anders) installiert. Dann ging der Rechner wieder
hoch, und konnte ich ruhig nachgehen was das Problem mit Grub eigentlich war.

Ich kann mich nicht mehr erinnern was dein anfängliches Problem war. Alles
funktionierte bis du etwas ändertest, oder so?
>
> Alle hier gemachten Vorschläge sind bislang ohne Erfolg geblieben.

Viel Erfolg, so lernt man.

Ulrich
--

¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø
My Box said: "Install WinXP/Vista/Longhorn (what ever) or better ..."
So I installed Linux.
¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø,¸¸,ø¤º°`°º¤ø

< Previous Next >
Follow Ups