Mailinglist Archive: opensuse-de (2429 mails)

< Previous Next >
Suse 9.3 und Sound-Problem
  • From: Joerg Kampmann <joerg-at-ibk@xxxxxx>
  • Date: Thu, 26 Jan 2006 11:38:44 +0100
  • Message-id: <43D8A6B4.6090901@xxxxxx>

Hallo Gruppe,

ich habe Suse 9.3 auf einem Notebook Siemens-Fujitsu Amilo M 7400. Es
gibt ein paar grundsätzliche Probleme mit dem Sound von ALSA:

Was geht, ist:

cat < /dev/dsp > /dev/audio

weiteres Beispiel:

kampmann@ibk-node14:~/Tests/Aufnahmen> cat < /dev/dsp > cat.dev-dsp.raw
kampmann@ibk-node14:~/Tests/Aufnahmen> cat cat.dev-dsp.raw > /dev/audio

Funktioniert auch, wenn auch fürchterlich übersteuert.

folgendes ist offensichtlich der Fall:

kampmann@ibk-node14:~/Tests/Aufnahmen> arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel
82801DB-ICH4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 1: Intel ICH - MIC ADC
[Intel 82801DB-ICH4 - MIC ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 2: Intel ICH - MIC2
ADC [Intel 82801DB-ICH4 - MIC2 ADC]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 3: Intel ICH - ADC2
[Intel 82801DB-ICH4 - ADC2]
Subdevices: 1/1
Subdevice #0: subdevice #0

kampmann@ibk-node14:~/Tests/Aufnahmen> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel
82801DB-ICH4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958
[Intel 82801DB-ICH4 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0

kampmann@ibk-node14:~/Tests/Aufnahmen>

less /proc/asound/devices --- ergibt:
20: [0- 4]: digital audio playback
27: [0- 3]: digital audio capture
26: [0- 2]: digital audio capture
25: [0- 1]: digital audio capture
16: [0- 0]: digital audio playback
24: [0- 0]: digital audio capture
0: [0- 0]: ctl
1: : sequencer
33: : timer

Als Superuser kann ich /dev/audio benutzen !!! ->

kampmann@ibk-node14:~/Tests/Aufnahmen> su
Password:
ibk-node14:/home/kampmann/Tests/Aufnahmen # aplay test01.wav
Playing WAVE 'test01.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Aborted by signal Interrupt...
ibk-node14:/home/kampmann/Tests/Aufnahmen # exit
exit
kampmann@ibk-node14:~/Tests/Aufnahmen> aplay test01.wav
aplay: main:533: audio open error: Permission denied
kampmann@ibk-node14:~/Tests/Aufnahmen>

die Rechte scheinen ok zu sein

kampmann@ibk-node14:~/Tests/Aufnahmen> ll /dev/audio
crw------- 1 kampmann audio 14, 4 2005-03-19 20:36 /dev/audio
kampmann@ibk-node14:~/Tests/Aufnahmen>

kampmann@ibk-node14:~/Tests/Aufnahmen> id
uid=1000(kampmann) gid=100(users) Gruppen=16(dialout),17(audio),33(video),100(users),1000(Astro)
kampmann@ibk-node14:~/Tests/Aufnahmen>

Meine Frage: was ist da nicht in Ordnung ... ??
Würde mich sehr über eine prompte Antwort freuen ... Danke
Jörg

< Previous Next >
Follow Ups