Mailinglist Archive: opensuse-de (3513 mails)

< Previous Next >
Re: Berkeley DB 3.x or later was not found
  • From: Andreas Winkelmann <ml@xxxxxxxxxxxxxx>
  • Date: Sat, 11 Dec 2004 16:08:23 +0100
  • Message-id: <200412111608.23290.ml@xxxxxxxxxxxxxx>
Am Samstag, 11. Dezember 2004 15:29 schrieb joerg ries:

in meinem Thread vom 2.12.2004 "Cyrus,Postix,mySQL->Unable to set file
descriptors limit to -1" bat ich schon mal um Hilfe. Das Ganze hat auch
soweit geklappt.
Da ich mich irgendwie in eine Sackgasse manövriert habe und wahrscheinlich
einiges am System verbogen habe, installierte ich 'Suse 9.1' komplett neu.

Folgendes wurde danach in dieser Reihenfolge aus den heruntergeladenen
Quellen kompiliert und installiert:
openssl-0.9.7e

Wozu? Di bei der Suse beigelegte ist doch ok.

#Nach Anleitung: http://www.sleepycat.com/docs/ref/toc.html
berkeleydb-4.2.52.nc

Wieso hast Du das denn gemacht? Die 4.2.52 ist doch bei der 9.1 dabei.

cyrus-sasl-2.1.20

Nun wollte ich 'cyrus-imapd-2.2.9' kompilieren. Doch leider bekomme ich
beim Aufruf von
./configure \
--with-sasl=/usr/local/lib \
--with-perl \
--with-auth=unix \
--with-dbdir=/usr/local/Berkeley.4.2\
--with-bdb-libdir=/usr/local/Berkeley.4.2/lib \
--with-bdb-incdir=/usr/local/Berkeley.4.2/include \
--with-openssl=/usr/local/ssl \
--without-ucdsnmp \

Wozu ist der "\" in der letzten Zeile? Fehlt da noch was?

folgende Fehlermeldung:
configure: error: Berkeley DB 3.x or later was not found. You may need to
supply the --with-bdb-libdir or --with-bdb-incdir configure options.

Kann mir jemand etwas auf die Sprünge helfen?

Schau doch mal ins config.log in diesem Verzeichnis.

--
Andreas

< Previous Next >
Follow Ups
References