Mailinglist Archive: opensuse-de (4464 mails)

< Previous Next >
Re: Link auf init.d script: scrip t wird nicht ausgeführt
  • From: Ralf Carlet <ralf@xxxxxxxxx>
  • Date: Thu, 18 Sep 2003 23:48:58 +0200
  • Message-id: <3F6A284A.1020807@xxxxxxxxx>
N'abend!

Timo Nentwig schrieb:
Ich habe mir ein script in /etc/init.d/ geschrieben und u.a. mit YaST
mit die entsprechenden rc* links setzen lassen. Die sind auch da und
sind gültig.

Nur das script wird nicht ausgeführt.

Das script selbst funktioniert tadellos und ich kanns mit <script>
start

auch starten und alles, nur bei

<rc link> start

passiert gar nichts; ich frag mich, was er da aufruft, wenn
überhaupt, aber scheinbar nicht das script, zu dem der link führt...

Grosses Fragezeichen. Wer kann mich helfen?

Also mir ist nicht ganz klar wie Du vorgegangen bist, und ich habe auch
SuSE 7.3. Aber ich habe heute dasselbe Ziel verfolgt wie Du und es hat
mit Handarbeit funktioniert. Ich habe Spamassassin kompiliert und den
SPAMD in die Startskripte Runlevel 3 und 5 eingebunden.

Vielleicht hilft Dir zu hören wie ich vorgegangen bin (evtl. mußt Du
Pfade anpassen):
- Skript in /etc/init.d erstellt, in dem ich ein anderes kopiert und
angepasst habe
- das neue Skript ausprobiert mit start und stop
- Symbolischen Link (ln -s) in /sbin gemacht: ln -s /etc/init.d/spamd
rcspamd gemacht und getestet (jetzt hab ich ein rcspamd)
- in den Runleveln 3 und 5 will ich SPAMD starten, also in
/etc/init.d/rc3.d und .../rc5.d die entsprechenden symbolischen Links
erstellt
- getestet
- gefreut das es klappt ;-)

Geholfen hat mir auch /etc/init.d/README

Ich habe *nicht* mit YAST oder so rumgearbeitet, weil ich lieber von
Hand lernen mag wie es geht.

Vielleicht hilfts ja, wäre schön,

Ralf
--
:: Ralf Carlet :: Fon & Fax: +49-(0)700-RALFCARLET
:: eMail: ralf@xxxxxxxxx :: Web: http://www.carlet.de
:: () ascii ribbon campaign - gegen html mail
:: /\ - gegen proprietäre attachments



< Previous Next >
References