Mailinglist Archive: opensuse-de (5395 mails)

< Previous Next >
RE: Lilo
  • From: artus-ol@xxxxxxx (Oliver Leue)
  • Date: Tue Feb 01 12:58:46 2000
  • Message-id: <XFMail.000201135846.artus-ol@xxxxxxx>



On 01-Feb-00 Michael Lehmann wrote:

> Ich habe ein Problem mit dem Lilo. Ich habe 2 Festplatten im System. Auf
> der ersten ist Linux, auf der Zweiten Win98. Nun kann ich mit lilo Linux
> ohne Probleme starten, nicht aber Windows. Es erscheint nur die Meldung
> "Loading Win". Dann ist schluss.

ich gehe einmal davon aus, daß die erste platte auch aktiv ist. :)

dann geht das so nicht. ALLE microsoft-betriebssysteme benötigen die erste
partition der ersten festplatte. das ist die erste partition der aktiven
platte. bei dir also hda1. und zwar zwingend. die partition kann ruhig die
mindestgröße haben, also 2 mb, wenn du das windows-verzeichnis auf eine andere
platte legst. diese partition erscheint dann unter windows als C:.

o wie du das hast, geht es nicht. entweder gehst du nun her und tauschst die
festplatten aus, läßt von windows den mbr neu beschreiben und hast bereits
vorher in linux alle parameter geändert die auf die dev/hda* weisen und
installierst anschließend nachdm du per diskette linux neu gebootet hast,
lilo neu oder du setzt die zweite festplatte als aktiv und dann das gleiche
spiel mit dem mbr oder du mußt neu installieren. es gibt keine andere
möglichkeit. windows braucht immer die erste partition der ersten
(aktiven) platte um dort seine für das booten notwendigen systemdateien zu
installieren.

----------------------------------
E-Mail: Oliver Leue <artus-ol@xxxxxxx>
Date: 01-Feb-00
Time: 13:58:46

This message was sent by XFMail
----------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: suse-linux-unsubscribe@xxxxxxxx
For additional commands, e-mail: suse-linux-help@xxxxxxxx

< Previous Next >
References