Mailinglist Archive: opensuse-commit (1029 mails)

< Previous Next >
commit totem-pl-parser for openSUSE:Factory

Hello community,

here is the log from the commit of package totem-pl-parser for openSUSE:Factory
checked in at Fri Jul 8 10:47:53 CEST 2011.



--------
--- GNOME/totem-pl-parser/totem-pl-parser.changes 2011-05-26
21:52:12.000000000 +0200
+++ /mounts/work_src_done/STABLE/totem-pl-parser/totem-pl-parser.changes
2011-06-16 17:01:36.000000000 +0200
@@ -1,0 +2,20 @@
+Wed Jun 8 17:14:37 UTC 2011 - nmarques@xxxxxxxxxxxx
+
+- Move to pkgconfig() style BuildRequires:
+ + Old ones: glib2-devel, gmime-2_4-devel,
+ gobject-introspection-devel, libquvi-devel, libsoup-devel,
+ libxml2-devel.
+ + New ones: glib-2.0, gmime-2.4, gobject-introspection-1.0,
+ libquvi, libsoup-2.4, libxml-2.0.
+- Improved removal of libtool archives on spec.
+
+-------------------------------------------------------------------
+Wed Jun 1 12:26:33 CEST 2011 - vuntz@xxxxxxxxxxxx
+
+- Add libquvi-devel BuildRequires to enable Quvi video link
+ parsing. Fix bnc#676294.
+- Pass --enable-quvi to make sure quvi support is built-in; it will
+ make the build fail if we lose it for some reason, which is good
+ to not lose the feature silently.
+
+-------------------------------------------------------------------

calling whatdependson for head-i586


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ totem-pl-parser.spec ++++++
--- /var/tmp/diff_new_pack.Kql7XF/_old 2011-07-08 10:46:26.000000000 +0200
+++ /var/tmp/diff_new_pack.Kql7XF/_new 2011-07-08 10:46:26.000000000 +0200
@@ -20,20 +20,21 @@

Name: totem-pl-parser
Version: 2.32.5
-Release: 1
+Release: 2
License: LGPLv2.0+
Group: Productivity/Multimedia/Video/Players
Source0: %{name}-%{version}.tar.bz2
Summary: A simple GObject-based library to parse playlist formats
Url: http://www.gnome.org/projects/totem/
-BuildRequires: glib2-devel
-BuildRequires: gmime-2_4-devel
-BuildRequires: gobject-introspection-devel
BuildRequires: intltool
-BuildRequires: libsoup-devel
-BuildRequires: libxml2-devel
BuildRequires: translation-update-upstream
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gmime-2.4)
+BuildRequires: pkgconfig(gobject-introspection-1.0)
BuildRequires: pkgconfig(libarchive)
+BuildRequires: pkgconfig(libquvi)
+BuildRequires: pkgconfig(libsoup-2.4)
+BuildRequires: pkgconfig(libxml-2.0)
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Recommends: %{name}-lang

@@ -55,11 +56,13 @@

%lang_package
%prep
-%setup
+%setup -q
translation-update-upstream

%build
-%configure --disable-static
+%configure \
+ --disable-static \
+ --enable-quvi
make %{?jobs:-j%jobs}

%post -p /sbin/ldconfig
@@ -71,7 +74,7 @@
%if 0%{?suse_version} <= 1120
%{__rm} %{buildroot}%{_datadir}/locale/en@shaw/LC_MESSAGES/*
%endif
-rm $RPM_BUILD_ROOT/%{_libdir}/*.la
+find %{buildroot}%{_libdir} -name "*.la" -type f -print -delete
%find_lang %{name}

%clean


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

--
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages