Mailinglist Archive: opensuse-commit (1774 mails)

< Previous Next >
commit kdebase4-workspace for openSUSE:Factory

Hello community,

here is the log from the commit of package kdebase4-workspace for
openSUSE:Factory
checked in at Thu Feb 3 01:33:23 CET 2011.



--------
--- KDE/kdebase4-workspace/kdebase4-wallpapers.changes 2011-01-10
10:54:15.000000000 +0100
+++ /mounts/work_src_done/STABLE/kdebase4-workspace/kdebase4-wallpapers.changes
2011-01-26 15:27:17.000000000 +0100
@@ -0,0 +1,5 @@
+Wed Jan 19 23:37:13 CET 2011 - dmueller@xxxxxxx
+
+- update to 4.6.0
+ * For highlights, see http://kde.org/announcements/4.6
+
@@ -8 +12,0 @@
-
@@ -21 +24,0 @@
-
kdebase4-workspace.changes: same change
python-kdebase4.changes: same change

calling whatdependson for head-i586


Old:
----
kdebase-workspace-4.5.95.tar.bz2

New:
----
kdebase-workspace-4.6.0.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kdebase4-wallpapers.spec ++++++
--- /var/tmp/diff_new_pack.LhRzxg/_old 2011-02-03 01:27:00.000000000 +0100
+++ /var/tmp/diff_new_pack.LhRzxg/_new 2011-02-03 01:27:00.000000000 +0100
@@ -1,5 +1,5 @@
#
-# spec file for package kdebase4-wallpapers (Version 4.5.95)
+# spec file for package kdebase4-wallpapers
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
@@ -18,13 +18,15 @@


Name: kdebase4-wallpapers
-BuildRequires: libdbusmenu-qt-devel libkdepimlibs4-devel libqimageblitz-devel
License: GPLv2+
Group: System/GUI/KDE
Summary: KDE 4 Wallpapers
Url: http://www.kde.org/
-Version: 4.5.95
+Version: 4.6.0
Release: 1
+BuildRequires: libdbusmenu-qt-devel
+BuildRequires: libkdepimlibs4-devel >= %version
+BuildRequires: libqimageblitz-devel
Source0: kdebase-workspace-%version.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch

++++++ kdebase4-workspace.spec ++++++
--- /var/tmp/diff_new_pack.LhRzxg/_old 2011-02-03 01:27:00.000000000 +0100
+++ /var/tmp/diff_new_pack.LhRzxg/_new 2011-02-03 01:27:00.000000000 +0100
@@ -1,5 +1,5 @@
#
-# spec file for package kdebase4-workspace (Version 4.5.95)
+# spec file for package kdebase4-workspace
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
@@ -18,18 +18,24 @@


Name: kdebase4-workspace
-BuildRequires: ConsoleKit-devel
-BuildRequires: NetworkManager-devel
+License: GPLv2+
+Group: System/GUI/KDE
+Summary: The KDE Workspace Components
+Url: http://www.kde.org/
+Version: 4.6.0
+Release: 1
BuildRequires: audit-devel
BuildRequires: bluez-devel
+BuildRequires: ConsoleKit-devel
BuildRequires: fdupes
BuildRequires: google-gadgets-devel
BuildRequires: gpsd-devel
-BuildRequires: libQtWebKit-devel
BuildRequires: libdbusmenu-qt-devel
-BuildRequires: libkde4-devel
+BuildRequires: libkde4-devel >= %version
BuildRequires: libkdepimlibs4-devel
BuildRequires: liblazy-devel
+BuildRequires: libQtWebKit-devel
+BuildRequires: NetworkManager-devel
%if %suse_version < 1120
BuildRequires: libpolkit-qt-devel
%else
@@ -53,12 +59,6 @@
%if %suse_version > 1110
Requires: polkit-kde-agent-1 polkit-kde-kcmmodules-1
%endif
-License: GPLv2+
-Group: System/GUI/KDE
-Summary: The KDE Workspace Components
-Url: http://www.kde.org/
-Version: 4.5.95
-Release: 1
Source0: kdebase-workspace-%version.tar.bz2
Source1: rcksysguardd
Source2: titlebar_decor.png

++++++ python-kdebase4.spec ++++++
--- /var/tmp/diff_new_pack.LhRzxg/_old 2011-02-03 01:27:00.000000000 +0100
+++ /var/tmp/diff_new_pack.LhRzxg/_new 2011-02-03 01:27:00.000000000 +0100
@@ -1,5 +1,5 @@
#
-# spec file for package python-kdebase4 (Version 4.5.95)
+# spec file for package python-kdebase4
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
@@ -18,8 +18,6 @@


Name: python-kdebase4
-BuildRequires: NetworkManager-devel bluez-devel libQtWebKit-devel
libdbusmenu-qt-devel libkdepimlibs4-devel libqimageblitz-devel
-BuildRequires: libknotificationitem-devel libsmbclient-devel
libxklavier-devel python-kde4-devel
%if %suse_version > 1030
BuildRequires: ConsoleKit-devel libpolkit-qt-devel
%endif
@@ -28,8 +26,10 @@
Group: System/GUI/KDE
Summary: Python bindings for KDE 4 desktop shell
Url: http://www.kde.org/
-Version: 4.5.95
+Version: 4.6.0
Release: 1
+BuildRequires: NetworkManager-devel bluez-devel libQtWebKit-devel
libdbusmenu-qt-devel libkdepimlibs4-devel >= %version libqimageblitz-devel
+BuildRequires: libknotificationitem-devel libsmbclient-devel
libxklavier-devel python-kde4-devel >= %version
Source0: kdebase-workspace-%version.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: python-kde4 = %{version}

++++++ 4_6_BRANCH.diff ++++++
--- /var/tmp/diff_new_pack.LhRzxg/_old 2011-02-03 01:27:00.000000000 +0100
+++ /var/tmp/diff_new_pack.LhRzxg/_new 2011-02-03 01:27:00.000000000 +0100
@@ -5,3 +5,24 @@
@@ -0,0 +1,2 @@
+current HEAD: 1204116
+svn di between //trunk/KDE/kdebase/workspace@1149349 and
//trunk/KDE/kdebase/workspace
+--- startkde.cmake.orig 2011-01-26 15:21:14.856499000 +0100
++++ startkde.cmake 2011-01-26 15:21:24.559585000 +0100
+@@ -36,18 +36,6 @@
+ # we have to unset this for Darwin since it will screw up KDE's
dynamic-loading
+ unset DYLD_FORCE_FLAT_NAMESPACE
+
+-# Enable lightweight memory corruption checker if not already set
+-# -- this is for trunk only, we remove it for releases
+-if [ "x$MALLOC_CHECK_" = "x" ] && [ -x /lib/libc.so.6 ]; then
+- # Extract the first two components of the version from the output.
+- glibc_version=$(LC_ALL=C /lib/libc.so.6 | sed -e
's/[^0-9]*\([0-9]\.[0-9]\+\).*/\1/;s/\.\([0-9]\)$/.0\1/;q')
+-
+- MALLOC_CHECK_=2 # Default to 2 unless glibc 2.9 or higher.
+- test $glibc_version \> 2.08 && MALLOC_CHECK_=3
+-
+- export MALLOC_CHECK_
+-fi
+-
+ # in case we have been started with full pathname spec without being in PATH
+ bindir=`echo "$0" | sed -n 's,^\(/.*\)/[^/][^/]*$,\1,p'`
+ if [ -n "$bindir" ]; then

++++++ kdebase-workspace-4.5.95.tar.bz2 -> kdebase-workspace-4.6.0.tar.bz2
++++++
KDE/kdebase4-workspace/kdebase-workspace-4.5.95.tar.bz2
/mounts/work_src_done/STABLE/kdebase4-workspace/kdebase-workspace-4.6.0.tar.bz2
differ: char 11, line 1




++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

--
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >