Mailinglist Archive: opensuse-commit (769 mails)

< Previous Next >
commit gpgme for openSUSE:Factory
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Mon, 29 Jun 2009 16:50:42 +0200
  • Message-id: <20090629145043.30771678161@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package gpgme for openSUSE:Factory
checked in at Mon Jun 29 16:50:42 CEST 2009.


--------
--- gpgme/gpgme.changes 2009-06-11 11:20:52.000000000 +0200
+++ gpgme/gpgme.changes 2009-06-23 14:07:13.000000000 +0200
@@ -1,0 +2,20 @@
+Tue Jun 23 14:00:38 CEST 2009 - puzel@xxxxxxxxxx
+
+- update to gpgme-1.2.0
+ * New encryption flag GPGME_ENCRYPT_NO_ENCRYPT_TO to disable default
+ recipients.
+ * gpgme_new will fail if gpgme_check_version was not called, or a
+ selftest failed (for example, if -mms-bitfields was not used on
+ MingW32 targets).
+ * New functions gpgme_io_read and gpgme_io_write for use with
+ gpgme_passphrase_cb_t and gpgme_edit_cb_t functions.
+ * New functions gpgme_result_ref and gpgme_result_unref to detach
+ result structures from a context.
+ * New functions gpgme_op_export_keys_start and gpgme_op_export_keys
+ that allow to specify exported keys through gpgme_key_t objects
+ instead of patterns.
+ * New mode of operation gpgme_export_mode_t that allows exporting
+ external keys.
+- drop unneeded BRs: libgcrypt-devel, libksba-devel
+
+-------------------------------------------------------------------

calling whatdependson for head-i586


Old:
----
gpgme-1.1.8.tar.bz2

New:
----
gpgme-1.2.0.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gpgme.spec ++++++
--- /var/tmp/diff_new_pack.y24864/_old 2009-06-29 16:44:45.000000000 +0200
+++ /var/tmp/diff_new_pack.y24864/_new 2009-06-29 16:44:45.000000000 +0200
@@ -1,5 +1,5 @@
#
-# spec file for package gpgme (Version 1.1.8)
+# spec file for package gpgme (Version 1.2.0)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
@@ -19,15 +19,17 @@


Name: gpgme
-BuildRequires: gpg2 libgcrypt-devel libksba-devel libpth-devel
+BuildRequires: gpg2 >= 2.0.10
+BuildRequires: libpth-devel >= 2.0.7
+BuildRequires: libgpg-error-devel >= 1.4
License: GPL v2 or later
Group: Productivity/Security
PreReq: %install_info_prereq
AutoReqProv: on
-Version: 1.1.8
-Release: 4
+Version: 1.2.0
+Release: 1
Source: ftp://ftp.gnupg.org/gcrypt/gpgme/%{name}-%{version}.tar.bz2
-Patch1: %{name}-%{version}-makecheck.patch
+Patch1: %{name}-1.1.8-makecheck.patch
Url: http://www.gnupg.org/related_software/gpgme/
Summary: A Library Designed to Give Applications Easy Access to GnuPG
Requires: gpg2
@@ -197,141 +199,3 @@
%{_includedir}/gpgme.h

%changelog
-* Thu Jun 11 2009 puzel@xxxxxxx
-- change BuildRequires: (pth-devel -> libpth-devel)
-* Tue Jun 02 2009 dmueller@xxxxxxx
-- fix requires of devel package
-* Mon Jun 01 2009 puzel@xxxxxxx
-- BuildRequires: pth-devel
-* Wed Feb 18 2009 puzel@xxxxxxx
-- update to 1.1.8
- * SIGPIPE is now again ignored as described in the manual. Fixes
- regresion introduced with 1.1.6.
-* Mon Dec 08 2008 puzel@xxxxxxx
-- update to 1.1.7
- - using GPGME_KEYLIST_MODE_LOCAL combined with
- GPGME_KEYLIST_MODE_EXTERN is now supported
- - the encoding of gpgme_data_t objects can affect the output encoding
- of export, sign and encrypt operations now
- - the reference manual now includes the specification of "The GnuPG
- UI Server protocol"
- - a new function gpgme_cancel_async can be used to asynchronously
- cancel any pending operation at any time, from any thread
-- remove gpgme-1.1.6-from-upstream.patch (fixed upstream)
-- remove gpgme-1.1.4-warning.patch (fixed upstream)
-- fix obsolete usage of run_ldconfig
-* Thu Apr 10 2008 ro@xxxxxxx
-- added baselibs.conf file to build xxbit packages
- for multilib support
-* Wed Feb 06 2008 bk@xxxxxxx
-- update to version 1.1.6: API extensions, eg for gpgconf thru gpgme
-- add upstream patches to run the testsuite non-interactively
-* Thu Dec 27 2007 crrodriguez@xxxxxxx
-- fix library-without-ldconfig-post* errors
-- remove "la" files
-* Wed Aug 08 2007 ro@xxxxxxx
-- remove devel requires from library package
-* Tue Aug 07 2007 mrueckert@xxxxxxx
-- add defattr to the lib package
-* Mon Aug 06 2007 zpetrova@xxxxxxx
-- split gpgme to libgpgme11 and gpgme.
-* Fri Jul 27 2007 zpetrova@xxxxxxx
-- update to version 1.1.5
- - small bug and portability fixes.
-* Wed May 16 2007 zpetrova@xxxxxxx
-- removed gpg from Requires list. (#273491)
-* Mon Mar 12 2007 zpetrova@xxxxxxx
-- updated filelist
-* Fri Mar 09 2007 ltinkl@xxxxxxx
-- update to latest version (1.1.4), needed for gpa
- * Detect and bail out on double plaintext messages. This is required
- so that applications can properly detect the signed parts of a
- message. Actual there is now a double protection as GnuPG 1.4.7
- will detect this case too.
- * Fixed a memory leak in gpgme_data_release_and_get_mem.
- * Fixed a bug in Windows command line quoting.
-* Mon Feb 05 2007 ro@xxxxxxx
-- updated filelist
-* Wed Sep 20 2006 anosek@xxxxxxx
-- fixed compiler warning: variable "key" is used before its value
- is set [#159104] (warning.patch)
-* Mon Jul 17 2006 nadvornik@xxxxxxx
-- fixed pthread support in gpgme-config
-* Wed Jun 28 2006 zpetrova@xxxxxxx
-- update to version 1.1.2
-* Thu Jan 26 2006 sbrabec@xxxxxxx
-- Added %%install_info_prereq.
-* Wed Jan 25 2006 mls@xxxxxxx
-- converted neededforbuild to BuildRequires
-* Sun Jan 15 2006 kukuk@xxxxxxx
-- Create devel subpackage [#140727]
-* Sat Dec 03 2005 meissner@xxxxxxx
-- require libgpg-error-devel (since we include headers that
- include headers from there).
-* Mon Nov 28 2005 zpetrova@xxxxxxx
-- Update to version 1.0.3 (#135395).
-* Thu Feb 17 2005 didge@xxxxxxx
-- update to stable version 1.0.2
-- update of url
-* Mon Jul 12 2004 adrian@xxxxxxx
-- update to version 0.9.0
- * support for gpg2
-* Thu Mar 18 2004 didge@xxxxxxx
-- fixed bug #36194
-* Fri Feb 27 2004 ro@xxxxxxx
-- added libgpg-error to neededforbuild
-* Mon Feb 09 2004 didge@xxxxxxx
-- version 0.3.16
-* Sat Jan 10 2004 adrian@xxxxxxx
-- add %%run_ldconfig
-* Tue Sep 02 2003 mc@xxxxxxx
-- add newpg, libgcrypt and libksba to neededforbuild again
- it is needed to support kmail with cryptplug
- fixed #29620, #29641 and #29642
-* Mon Aug 11 2003 adrian@xxxxxxx
-- cleanup #neededforbuild and requires
-* Tue Aug 05 2003 adrian@xxxxxxx
-- fix libtool handling to get shared libraries
-* Thu May 22 2003 coolo@xxxxxxx
-- fixing info pages
-* Wed Apr 16 2003 coolo@xxxxxxx
-- use BuildRoot
-* Fri Feb 21 2003 mc@xxxxxxx
-- fixed -fPIC and lib64 Problems
-* Thu Feb 20 2003 mc@xxxxxxx
-- update to version 0.3.15
-* Thu Jan 30 2003 didge@xxxxxxx
-- Version 0.3.14
-* Mon Oct 21 2002 didge@xxxxxxx
-- Version 0.3.12
-* Wed Sep 25 2002 ro@xxxxxxx
-- removed bogus self-provides again
-* Wed Sep 25 2002 didge@xxxxxxx
-- Version 0.3.11
-* Tue Sep 10 2002 didge@xxxxxxx
-- Version 0.3.10
-* Wed Jul 31 2002 didge@xxxxxxx
-- Version 0.3.8
-* Fri Jun 21 2002 didge@xxxxxxx
-- New Version 0.3.7
-* Fri May 10 2002 didge@xxxxxxx
-- New Version 0.3.6
-* Tue May 07 2002 ro@xxxxxxx
-- fixed specfile: no macro allowed in Version: line
-* Fri Mar 08 2002 didge@xxxxxxx
-- New Version 0.3.4
-* Thu Feb 14 2002 didge@xxxxxxx
-- New Version 0.3.3
-* Fri Jan 04 2002 didge@xxxxxxx
-- New Version 0.3.0
-* Wed Oct 31 2001 didge@xxxxxxx
-- Fixed patch
-* Mon Oct 29 2001 didge@xxxxxxx
-- Needs a patch to build on other platforms than i386
-* Tue Oct 09 2001 didge@xxxxxxx
-- Version 0.2.3
-- needs a patch to build because something is broken?!
-* Thu Sep 13 2001 didge@xxxxxxx
-- Fix a bug to build under AXP
-* Wed Aug 22 2001 didge@xxxxxxx
-- First build, Verison 0.2.2

++++++ gpgme-1.1.8.tar.bz2 -> gpgme-1.2.0.tar.bz2 ++++++
++++ 37445 lines of diff (skipped)


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

--
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread