Mailinglist Archive: opensuse-commit (910 mails)

< Previous Next >
commit libxml++ for openSUSE:Factory
  • From: root@xxxxxxxxxxxxxxx (h_root)
  • Date: Wed, 25 Mar 2009 19:32:10 +0100
  • Message-id: <20090325183210.CB56D678161@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package libxml++ for openSUSE:Factory
checked in at Wed Mar 25 19:32:10 CET 2009.


--------
--- GNOME/libxml++/libxml++.changes 2009-03-06 17:05:30.000000000 +0100
+++ libxml++/libxml++.changes 2009-03-16 22:27:46.000000000 +0100
@@ -2 +2,8 @@
-Fri Mar 6 17:03:47 CET 2009 - vuntz@xxxxxxxxxx
+Mon Mar 16 22:26:08 CET 2009 - vuntz@xxxxxxxxxx
+
+- Update to version 2.26.0:
+ + Increased version number to match GNOME 2.26.
+- Remove AutoReqProv: it's default now.
+
+-------------------------------------------------------------------
+Sat Mar 14 00:55:00 CET 2009 - mboman@xxxxxxx
@@ -5,4 +12,3 @@
- + TextReader: Actually throw exceptions on errors.
- (This breaks ABI but we do not believe that this class could be
- used with this problem so it should not actually break any
- application.) bgo#348006.
+ + TextReader: Actually throw exceptions on errors (This breaks
+ ABI but we do not believe that this class could be used with
+ this problem so it should not actually break any application.)
@@ -9,0 +16 @@
+- Don't run autoreconf

calling whatdependson for head-i586


Old:
----
libxml++-2.24.3.tar.bz2

New:
----
libxml++-2.26.0.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libxml++.spec ++++++
--- /var/tmp/diff_new_pack.Y29298/_old 2009-03-25 19:30:49.000000000 +0100
+++ /var/tmp/diff_new_pack.Y29298/_new 2009-03-25 19:30:49.000000000 +0100
@@ -1,5 +1,5 @@
#
-# spec file for package libxml++ (Version 2.24.3)
+# spec file for package libxml++ (Version 2.26.0)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
@@ -19,11 +19,14 @@


Name: libxml++
-BuildRequires: fdupes gcc-c++ glibmm2-devel libxml2-devel update-desktop-files
+BuildRequires: fdupes
+BuildRequires: gcc-c++
+BuildRequires: glibmm2-devel
+BuildRequires: libxml2-devel
+BuildRequires: update-desktop-files
License: LGPL v2.1 or later
Group: Development/Libraries/C and C++
-AutoReqProv: on
-Version: 2.24.3
+Version: 2.26.0
Release: 1
Summary: C++ Interface for XML Files
Source: %{name}-%{version}.tar.bz2
@@ -62,7 +65,7 @@
%patch

%build
-ACLOCAL="aclocal -I scripts" autoreconf -f -i -v
+#ACLOCAL="aclocal -I scripts" autoreconf -f -i -v
%configure --disable-static --with-pic\
--libexecdir=%{_prefix}/lib/%name
make docdir=%{_docdir}/%{name}/docs %{?jobs:-j%jobs}
@@ -101,13 +104,17 @@
%doc %{_docdir}/%{name}/docs

%changelog
-* Fri Mar 06 2009 vuntz@xxxxxxxxxx
+* Mon Mar 16 2009 vuntz@xxxxxxxxxx
+- Update to version 2.26.0:
+ + Increased version number to match GNOME 2.26.
+- Remove AutoReqProv: it's default now.
+* Sat Mar 14 2009 mboman@xxxxxxx
- Update to version 2.24.3:
- + TextReader: Actually throw exceptions on errors.
- (This breaks ABI but we do not believe that this class could be
- used with this problem so it should not actually break any
- application.) bgo#348006.
+ + TextReader: Actually throw exceptions on errors (This breaks
+ ABI but we do not believe that this class could be used with
+ this problem so it should not actually break any application.)
+ Build: Windows: Remove unnecessary vsnprint define.
+- Don't run autoreconf
* Tue Jan 13 2009 crrodriguez@xxxxxxx
- remove static libraries and "la" files
- corrct -devel package dependencies

++++++ libxml++-2.24.3.tar.bz2 -> libxml++-2.26.0.tar.bz2 ++++++
++++ 2174 lines of diff (skipped)


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...

--
To unsubscribe, e-mail: opensuse-commit+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-commit+help@xxxxxxxxxxxx

< Previous Next >
This Thread