Mailinglist Archive: opensuse-commit (1187 mails)

< Previous Next >
commit yast2-installation
  • From: root@xxxxxxx (h_root)
  • Date: Mon, 24 Apr 2006 17:28:52 +0200 (CEST)
  • Message-id: <20060424152852.4FCDF8C453@xxxxxxxxxxxxxxx>

Hello community,

here is the log from the commit of package yast2-installation
checked in at Mon Apr 24 17:28:52 CEST 2006.

--------
--- yast2-installation/yast2-installation.changes 2006-04-24 13:14:18.000000000 +0200
+++ NOARCH/yast2-installation/yast2-installation.changes 2006-04-24 16:41:30.000000000 +0200
@@ -1,0 +2,12 @@
+Mon Apr 24 16:22:14 CEST 2006 - jsrain@xxxxxxx
+
+- GDM is default if both KDE and GNOME installed (#155095)
+- 2.13.88
+
+-------------------------------------------------------------------
+Mon Apr 24 13:30:50 CEST 2006 - sh@xxxxxxx
+
+- V 2.13.87
+- Removed "Disagree with all" button (bug #163001)
+
+-------------------------------------------------------------------

Old:
----
yast2-installation-2.13.86.tar.bz2

New:
----
yast2-installation-2.13.88.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ yast2-installation.spec ++++++
--- /var/tmp/diff_new_pack.295RA8/_old 2006-04-24 17:27:17.000000000 +0200
+++ /var/tmp/diff_new_pack.295RA8/_new 2006-04-24 17:27:17.000000000 +0200
@@ -1,5 +1,5 @@
#
-# spec file for package yast2-installation (Version 2.13.86)
+# spec file for package yast2-installation (Version 2.13.88)
#
# Copyright (c) 2006 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
@@ -11,12 +11,12 @@
# norootforbuild

Name: yast2-installation
-Version: 2.13.86
+Version: 2.13.88
Release: 1
License: GPL
Group: System/YaST
BuildRoot: %{_tmppath}/%{name}-%{version}-build
-Source0: yast2-installation-2.13.86.tar.bz2
+Source0: yast2-installation-2.13.88.tar.bz2
prefix: /usr
BuildRequires: docbook-xsl-stylesheets doxygen libxslt perl-XML-Writer sgml-skel update-desktop-files yast2 yast2-country yast2-devtools yast2-testsuite
Requires: yast2 yast2-update
@@ -48,7 +48,7 @@
Arvin Schnell <arvin@xxxxxxx>

%prep
-%setup -n yast2-installation-2.13.86
+%setup -n yast2-installation-2.13.88

%build
%{prefix}/bin/y2tool y2autoconf
@@ -106,6 +106,12 @@
/usr/X11R6/share/fvwm/

%changelog -n yast2-installation
+* Mon Apr 24 2006 - jsrain@xxxxxxx
+- GDM is default if both KDE and GNOME installed (#155095)
+- 2.13.88
+* Mon Apr 24 2006 - sh@xxxxxxx
+- V 2.13.87
+- Removed "Disagree with all" button (bug #163001)
* Mon Apr 24 2006 - ug@xxxxxxx
- 2.13.86
* Mon Apr 24 2006 - ug@xxxxxxx

++++++ yast2-installation-2.13.86.tar.bz2 -> yast2-installation-2.13.88.tar.bz2 ++++++
++++ 3029 lines of diff (skipped)
++++ retrying with extended exclude list
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/Makefile.am new/yast2-installation-2.13.88/Makefile.am
--- old/yast2-installation-2.13.86/Makefile.am 2006-04-24 12:36:20.000000000 +0200
+++ new/yast2-installation-2.13.88/Makefile.am 2006-04-24 16:42:16.000000000 +0200
@@ -6,7 +6,8 @@
# (Edit ./SUBDIRS instead)
#

-PREFIX = /usr
+#where devtools are
+PREFIX := $(shell pkg-config --print-errors --variable=prefix yast2-devtools)

VERSION = $(shell cat $(srcdir)/VERSION)
RPMNAME = $(shell cat $(srcdir)/RPMNAME)
@@ -30,6 +31,10 @@
extra_COPYRIGHT_files = $(if $(HAS_YAST_LICENSE), $(COPYRIGHT_files_yast), $(COPYRIGHT_files_gpl))

AUTOMAKE_OPTIONS = foreign dist-bzip2
+# where devtools instal m4 snippets
+# argh, executed literally
+#ACLOCAL_AMFLAGS = -I $(PREFIX)/share/aclocal
+ACLOCAL_AMFLAGS = -I `if test -d ./devtools/admin; then echo ./devtools/admin; else pkg-config --print-errors --variable=datadir yast2-devtools; fi`/aclocal

Makefile.am.common: $(DEVTOOLS_DIR)/admin/Makefile.am.common
cmp -s $< $@ || cp -f $< $@
@@ -57,12 +62,8 @@

# info '(automake)Conditionals'
if CREATE_PKGCONFIG
-# pkg-config
-# if a package does not have its own pc, copy the generic one
-$(RPMNAME).pc.in: $(DEVTOOLS_DIR)/admin/generic.pc.in
- test -f $@ || cp -p $< $@
# create the file here instead of by configure
-# because the prerequisite is made here
+# because the prerequisite is made here (not anymore!)
# and we don't want any paths in y2autoconf
# info '(autoconf)config.status Invocation'
$(RPMNAME).pc: $(RPMNAME).pc.in
@@ -153,7 +154,7 @@
$(PREFIX)/bin/y2tool create-spec < $$i > $$here/package/$${newname} ; \
done

-package: check-up-to-date check-tagversion check-all-packages package-local
+package: check-up-to-date check-tagversion check-all-packages check-textdomain package-local

TAGVERSION = $(PREFIX)/bin/y2tool tagversion

@@ -198,6 +199,9 @@
false; \
fi

+check-textdomain:
+ $(PREFIX)/bin/y2tool check-textdomain $(srcdir)
+
stable: checkin-stable

checkin-stable: package
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/Makefile.am.common new/yast2-installation-2.13.88/Makefile.am.common
--- old/yast2-installation-2.13.86/Makefile.am.common 2006-04-24 12:36:20.000000000 +0200
+++ new/yast2-installation-2.13.88/Makefile.am.common 2006-04-24 16:42:16.000000000 +0200
@@ -9,7 +9,7 @@
# suffix mapping: info '(make)Static Usage'
# apply only to our modules, not external ones
${ybcfiles}: %.ybc: %.ycp $(ycpchook)
- Y2DIR=$(YCPC_Y2DIR) LD_LIBRARY_PATH=$(YCPC_LD_LIBRARY_PATH) $(bindir)/ycpc -c -M. -I. -q $(YCPCFLAGS) $<
+ Y2DIR=$(YCPC_Y2DIR) LD_LIBRARY_PATH=$(YCPC_LD_LIBRARY_PATH) ${YCPC} -c -M. -I. -q $(YCPCFLAGS) $<

# files to clean
CLEANFILES = ${ybcfiles}
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/VERSION new/yast2-installation-2.13.88/VERSION
--- old/yast2-installation-2.13.86/VERSION 2006-04-24 12:35:38.000000000 +0200
+++ new/yast2-installation-2.13.88/VERSION 2006-04-24 16:40:30.000000000 +0200
@@ -1 +1 @@
-2.13.86
+2.13.88
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/configure.in new/yast2-installation-2.13.88/configure.in
--- old/yast2-installation-2.13.86/configure.in 2006-04-24 12:36:20.000000000 +0200
+++ new/yast2-installation-2.13.88/configure.in 2006-04-24 16:42:16.000000000 +0200
@@ -3,7 +3,7 @@
dnl -- This file is generated by y2autoconf - DO NOT EDIT! --
dnl (edit configure.in.in instead)

-AC_INIT(yast2-installation, 2.13.86, http://www.suse.de/feedback, yast2-installation)
+AC_INIT(yast2-installation, 2.13.88, http://www.suse.de/feedback, yast2-installation)
dnl Check for presence of file 'RPMNAME'
AC_CONFIG_SRCDIR([RPMNAME])

@@ -17,7 +17,7 @@
AM_INIT_AUTOMAKE(tar-ustar) dnl searches for some needed programs

dnl Important YaST2 variables
-VERSION="2.13.86"
+VERSION="2.13.88"
RPMNAME="yast2-installation"
MAINTAINER="Jiri Srain <jsrain@xxxxxxx>"

@@ -110,8 +110,8 @@
AC_MSG_ERROR(xgettext is missing; please install gettext-devel.)
fi

-devtools_ybindir=`pkg-config --variable=ybindir yast2-devtools`
-devtools_yast2dir=`pkg-config --variable=yast2dir yast2-devtools`
+devtools_ybindir=`pkg-config --print-errors --variable=ybindir yast2-devtools`
+devtools_yast2dir=`pkg-config --print-errors --variable=yast2dir yast2-devtools`

dnl producing pkg-config for others?
AM_CONDITIONAL(CREATE_PKGCONFIG, test "x${CREATE_PKGCONFIG}" != x)
@@ -138,6 +138,10 @@
if test "$YCPMAKEDEP" = "false"; then
AC_MSG_ERROR([ycpmakedep is not installed])
fi
+AC_PATH_PROG(YCPC, ycpc, false, $PATH:$bindir)
+if test "$YCPC" = "false"; then
+ AC_MSG_ERROR([ycpc is not installed])
+fi

dnl Check packages expect and dejagnu
AC_PATH_PROG(MYEXPECT, expect, false)
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/control/docs/control-doc.xml new/yast2-installation-2.13.88/control/docs/control-doc.xml
--- old/yast2-installation-2.13.86/control/docs/control-doc.xml 2005-02-08 18:30:23.000000000 +0100
+++ new/yast2-installation-2.13.88/control/docs/control-doc.xml 2006-02-02 19:55:05.000000000 +0100
@@ -28,7 +28,7 @@
0.1
</revnumber>
<date>
- $Date: 2004-10-27 16:25:24 +0200 (Wed, 27 Oct 2004) $
+ $Date: 2004-10-27 08:25:24 -0600 (Wed, 27 Oct 2004) $
</date>
<revremark>Initial Release as PDF</revremark>
</revision>
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/src/clients/inst_default_desktop.ycp new/yast2-installation-2.13.88/src/clients/inst_default_desktop.ycp
--- old/yast2-installation-2.13.86/src/clients/inst_default_desktop.ycp 2006-03-20 11:04:49.000000000 +0100
+++ new/yast2-installation-2.13.88/src/clients/inst_default_desktop.ycp 2006-04-24 16:22:41.000000000 +0200
@@ -4,7 +4,7 @@
* Summary: Configure FAM according to control file and defauls WM
* Authors: Jiri Srain <jsrain@xxxxxxx>
*
- * $Id: inst_default_desktop.ycp 28481 2006-03-01 19:05:52Z jsrain $
+ * $Id: inst_default_desktop.ycp 30413 2006-04-24 14:20:29Z jsrain $
*
*/

@@ -17,18 +17,18 @@
if ( !Mode::update () )
{
map<string,map<string,string> > desktop_data = $[
- "kde" : $[
- "package" : "kdebase3-kdm",
- "wm" : "kde",
- "dm" : "kdm",
- "cursor" : "crystalwhite",
- ],
"gnome" : $[
"package" : "gdm",
"wm" : "gnome",
"dm" : "gdm",
"cursor" : "Industrial",
],
+ "kde" : $[
+ "package" : "kdebase3-kdm",
+ "wm" : "kde",
+ "dm" : "kdm",
+ "cursor" : "crystalwhite",
+ ],
"twm" : $[
"package" : "xorg-x11",
"wm" : "",
@@ -37,9 +37,9 @@
],
];

- string default_wm = "kde";
- string default_dm = "kdm";
- string default_cursor = "crystalwhite";
+ string default_wm = "gnome";
+ string default_dm = "gdm";
+ string default_cursor = "Industrial";

if (Packages::window_manager != "" && Packages::window_manager != nil)
{
@@ -86,10 +86,10 @@

y2debug ("All packages in the selection: %1", packages);

- list<string> desktop_order = ["kde", "gnome"];
+ list<string> desktop_order = ["gnome", "kde"];

boolean desktop_found = false;
- string selection_desktop = "kde";
+ string selection_desktop = "gnome";

// check what packages are in the default selection
// and adjust logon and window manager according to it
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/src/clients/inst_doit.ycp new/yast2-installation-2.13.88/src/clients/inst_doit.ycp
--- old/yast2-installation-2.13.86/src/clients/inst_doit.ycp 2005-08-02 17:47:35.000000000 +0200
+++ new/yast2-installation-2.13.88/src/clients/inst_doit.ycp 2006-04-24 16:20:09.000000000 +0200
@@ -6,7 +6,7 @@
*
* Purpose: Asks user to really do the installation/update.
*
- * $Id: inst_doit.ycp 24385 2005-07-28 07:18:22Z jsrain $
+ * $Id: inst_doit.ycp 30399 2006-04-24 11:32:42Z sh $
*/
{
textdomain "installation";
@@ -29,6 +29,8 @@
}
list<string> to_install = Pkg::GetPackages (`selected, true);
map<string,string> licenses = Pkg::PkgGetLicensesToConfirm (to_install);
+
+ // FIXME: Remove deny_all (bug #163001)
boolean deny_all = false;
foreach (string package, string license, licenses, {
if (deny_all)
@@ -52,9 +54,7 @@
// push button
`PushButton (`id (`accept), _("I &Agree")),
// push button
- `PushButton (`id (`deny), _("I &Disagree")),
- // push button
- `PushButton (`id (`deny_all), _("I D&isagree with All"))
+ `PushButton (`id (`deny), _("I &Disagree"))
)
);
UI::OpenDialog (popup);
@@ -66,6 +66,16 @@
{
ret = nil;
// help text
+
+
+// FIXME
+// FIXME
+// Remove reference to "Disagree with all" button (bug #163001) in help text
+// --sh 2006-04-24
+// FIXME
+// FIXME
+
+
string help = _("<p><b><big>License Confirmation</big></b><br>
The package in the headline of the dialog requires an explicit confirmation
of acceptance of its license.
diff -urN --exclude=CVS --exclude=.cvsignore --exclude=.svn --exclude=.svnignore --exclude Makefile.in --exclude configure --exclude config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 --exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh old/yast2-installation-2.13.86/src/modules/Register.ycp new/yast2-installation-2.13.88/src/modules/Register.ycp
--- old/yast2-installation-2.13.86/src/modules/Register.ycp 2006-04-24 11:51:57.000000000 +0200
+++ new/yast2-installation-2.13.88/src/modules/Register.ycp 2006-04-24 16:20:09.000000000 +0200
@@ -258,6 +258,7 @@
else
{ // (#164794)
boolean started = (boolean) SCR::Execute(.background.run_output_err, sr_bash_cmd );
+ // translators: busy popup while registering the system
UI::OpenDialog(`VBox( `Label( _("Contacting server...")),
`PushButton(`id(`abort), Label::AbortButton() )
) );


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



Remember to have fun...


< Previous Next >