Mailinglist Archive: opensuse-buildservice (105 mails)

< Previous Next >
Re: [opensuse-buildservice] Debian_Unstable build failures / libcrypt.so.1
On Sat, Dec 7, 2019 at 4:30 PM Harald Welte <laforge@xxxxxxxxxxxx> wrote:

Dear Neal,

thanks a lot for your quick follow-up.

On Sat, Dec 07, 2019 at 08:30:33AM -0500, Neal Gompa wrote:

Debian transitioned from libxcrypt1 to libcrypt2.

Interesting! However, I cannot find any libcrypt2 packages on
packages.debian.org,
nor does it appear to be installable even on my local Debian Unstable
installation.

As a workaround, add the following to your project config:

%if 0%{?debian} > 10
Preinstall: libcrypt2
%endif

Thanks again! that suggestion unfortunately doesn't appear to work. Now
the builds are unresolvable, as "nothing provides libcrypt2".


Looks like Debian 10 transitions to it, but then afterwards, it goes
to libcrypt1.

So the correct statement would be:

%if 0%{?debian} && 0%{?debian} < 11
Preinstall: libcrypt2
%endif

%if 0%{?debian} >= 11
Preinstall: libcrypt1
%endif

--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >