Mailinglist Archive: opensuse-buildservice (105 mails)

< Previous Next >
Re: [opensuse-buildservice] help with kiwi?
Am 2019-12-06 08:07, schrieb Adrian Schröter:
On Freitag, 6. Dezember 2019, 07:43:03 CET Mathias Homann wrote:
HI,

so I'm starting to figure out kiwi, and I have a .kiwi file that builds fine
locally, but on OBS it fails with lots of dependency issues...

could someone with more experience with kiwi please have a look?

home:lemmy04:astrotoolbox/baseimage <- there

you have a submit request 754584 doing the following:

1) your repository ordering seems to be random, this enforces older
packages over new ones leading to conflicts.

Added

OBS-UnorderedRepos

comment to advice OBS not to take repository order into account.

thanks a lot!



2) added some packages to avoid choice errors. Some should be done in our
template maybe ...

... I don't think so, because those come from the fact that I'm building a Live USB Stick image with "pretty much everything needed" to show off Plasma, AND Gnome, AND xfce4... "withRecommended".


3) remaining issue is

nothing provides libpulsecommon-13.0.so()(64bit) needed by
pulseaudio-module-gsettings

According to

osc buildinfo -d ...

the package pulseaudio-module-gsettings comes from your home project. So that
should be fixed there.

here's the thing: it *is* fixed there, the proper pulseaudio is in my home, including a libpulse0 rpm that provides libpulsecommon-13.0.so()(64bit).

I have no idea why it isn't used.




--
Mathias Homann
Mathias.Homann@xxxxxxxxxxxx
telegram: https://telegram.me/lemmy98
irc: [lemmy] on freenode and ircnet
obs: lemmy04
gpg key fingerprint: 8029 2240 F4DD 7776 E7D2 C042 6B8E 029E 13F2 C102
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups