Mailinglist Archive: opensuse-buildservice (80 mails)

< Previous Next >
[opensuse-buildservice] Re: arm builds on local OBS
Did you Preinstall: qemu-linux-user (or its debian equivalent)?

When I add that, I get an "unresolvable, nothing provides
qemu-linux-user". I did a zypper install of the package on the obs
appliance which acts as both the obs server and worker followed by
restart of the appliance, but no luck.

After some googling, I found that you are supposed to provide qemu
binary from a project instead of installing directly on the worker, so
I create a 'qemu-linux-user' project in my local OBS instance with a
`_link` to the official OBS package -

<link project='openSUSE.org:openSUSE:Leap:15.1:Update'
package='qemu-linux-user'/>

Still no luck. qemu-linux-user shows 'excluded' under the Raspbian 10
repository for arm7vl

Appreciate any pointers.

Srivats

On Mon, Nov 4, 2019 at 8:58 PM Andreas Schwab <schwab@xxxxxxx> wrote:

On Nov 04 2019, Srivats P wrote:

I have the following in the project config to crossbuild armv7 on a
x86_64 worker
%ifarch armv7l
Hostarch: x86_64
Macros:
%qemu_user_space_build 1
:Macros
%endif

Did you Preinstall: qemu-linux-user (or its debian equivalent)?

Andreas.

--
Andreas Schwab, SUSE Labs, schwab@xxxxxxx
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups