Mailinglist Archive: opensuse-buildservice (93 mails)

< Previous Next >
[opensuse-buildservice] Re: issue with local build of image template
On Wed, Jul 3, 2019 at 3:28 PM Andreas Schwab <schwab@xxxxxxxxxxxxxx> wrote:

On Jul 03 2019, Bryan Gartner <bwgartner@xxxxxxxxx> wrote:

Any suggested fix/workaround?

Check extra-pkgs in your ~/.oscrc.

First, great hint ... thanks, Andreas!

While the file you cited did not exist on my system (which was just
built from scratch to help document the end-to-end image build process),
the root cause was in the corresponding ~/.config/osc/oscrc file.

The tmux issue was based on a blind cut-n-paste of the instructions in:
https://en.opensuse.org/openSUSE:OSC
(see Recommended starter configuration section).

Removing that package reference there, allowed the local image
build process to process much farther ... (so now on to the next issue)

...
[ 506s] Jul-03 22:10:31 <1> : Creating grub2 boot partition map
[ 506s] Jul-03 22:10:31 <1> : --> Using fs-uuid search method
[ 506s] Jul-03 22:10:31 <1> : grub search fs-uuid:
bfd27323-8690-47cf-a2d6-3878811a31b9
[ 506s] Jul-03 22:10:31 <1> : Importing grub2 stage and theming files
[ 506s] Jul-03 22:10:31 <1> : EXEC [gzip -9 -cd
/usr/src/packages/KIWI-oem/oem/initrd-oemboot-suse-SLES12.x86_64-2.7.1.splash.gz
2>&1 | \
[ 506s] (cd /tmp/kiwiboot.ZcwxUu && cpio -i -d
'usr/share/grub2/themes/*' -d 'usr/lib/grub2/i386-pc/*' 2>&1)]
[ 510s] Jul-03 22:10:35 <1> : EXEC [mv
/tmp/kiwiboot.ZcwxUu/usr/share/grub2/themes
/tmp/kiwiboot.ZcwxUu/boot/grub2 2>&1]
[ 510s] Jul-03 22:10:35 <1> : EXEC [cp
/tmp/kiwiboot.ZcwxUu/usr/lib/grub2/i386-pc/*
/tmp/kiwiboot.ZcwxUu/boot/grub2/i386-pc 2>&1]
[ 510s] Jul-03 22:10:35 <1> : Creating grub2 core boot image
[ 510s] Jul-03 22:10:35 <1> : EXEC [/usr/bin/grub2-mkimage -O i386-pc
-o /tmp/kiwiboot.ZcwxUu/boot/grub2/i386-pc/core.img -c
/tmp/kiwiboot.ZcwxUu/boot/grub2/bootpart.cfg -p /boot/grub2 -d
/tmp/kiwiboot.ZcwxUu//usr/lib/grub2/i386-pc part_msdos part_gpt chain
biosdisk vga vbe multiboot ext2 iso9660 linux echo configfile
search_label search_fs_file search search_fs_uuid ls normal gzio png
fat gettext font minicmd gfxterm gfxmenu video video_fb boot 2>&1]
[ 510s] Jul-03 22:10:35 <1> : Additional commandline options: "quiet"
[ 510s] Jul-03 22:10:35 <1> : Saving disk label boot/mbrid: 0x61f00226...
[ 510s] Jul-03 22:10:35 <1> : EXEC [mkdir -p /tmp/kiwiboot.ZcwxUu/boot]
[ 510s] Jul-03 22:10:35 <1> : EXEC [cp /usr/share/grub2/unicode.pf2
/tmp/kiwiboot.ZcwxUu/boot]
[ 510s] Jul-03 22:10:35 <1> : Creating grub2 configuration file...
[ 510s] Jul-03 22:10:35 <1> : EXEC [mkdir -p /tmp/kiwiboot.ZcwxUu/boot/grub2]
[ 510s] Use of uninitialized value in string eq at
/usr/share/kiwi/modules/KIWIBoot.pm line 4614.
[ 510s] Jul-03 22:10:35 <1> : EXEC [blkid /dev/mapper/loop0p1 -s TYPE
-o value 2>/dev/null]
[ 510s] Jul-03 22:10:35 <1> : EXEC [blkid /dev/mapper/loop0p1 2>/dev/null]
[ 510s] Jul-03 22:10:35 <1> : EXEC [pvs --noheadings -o vg_name
/dev/mapper/loop0p1 2>/dev/null]
[ 510s] Jul-03 22:10:35 <1> : EXEC [blkid -o value -s TYPE /dev/mapper/loop0p1]
[ 510s] Jul-03 22:10:35 <1> : EXEC [mount -n /dev/mapper/loop0p1
/tmp/kiwiloop.r3dvbE 2>&1]
[ 511s] Jul-03 22:10:36 <1> : EXEC [cp -dR /tmp/kiwiboot.ZcwxUu/boot
/tmp/kiwiloop.r3dvbE 2>&1]
[ 511s] Jul-03 22:10:36 <1> : EXEC [sync]
[ 513s] Jul-03 22:10:38 <1> : EXEC [umount /tmp/kiwiloop.r3dvbE 2>&1]
[ 514s] Jul-03 22:10:38 <1> : Creating grub2 device map
[ 514s] Jul-03 22:10:39 <1> : EXEC [blkid /dev/mapper/loop0p1 -s TYPE
-o value 2>/dev/null]
[ 514s] Jul-03 22:10:39 <1> : EXEC [blkid /dev/mapper/loop0p1 2>/dev/null]
[ 514s] Jul-03 22:10:39 <1> : EXEC [pvs --noheadings -o vg_name
/dev/mapper/loop0p1 2>/dev/null]
[ 514s] Jul-03 22:10:39 <1> : EXEC [blkid -o value -s TYPE /dev/mapper/loop0p1]
[ 514s] Jul-03 22:10:39 <1> : EXEC [mount -n /dev/mapper/loop0p1
/tmp/kiwiboot.LZ3lKV 2>&1]
[ 514s] Jul-03 22:10:39 <1> : EXEC [cp -a
/tmp/kiwiboot.LZ3lKV/boot/grub2/i386-pc
/tmp/kiwiboot.ZcwxUu/boot/grub2/ 2>&1]
[ 514s] Jul-03 22:10:39 <1> : Installing grub2:
[ 514s] Jul-03 22:10:39 <1> : --> On disk target:
/usr/src/packages/KIWI-oem/oem/SLES_12_SP3_JeOS.x86_64-1.0.0.raw
[ 514s] Jul-03 22:10:39 <1> : EXEC [/usr/sbin/grub2-bios-setup -f -d
/tmp/kiwiboot.ZcwxUu/boot/grub2/i386-pc -m
/tmp/kiwiboot.ZcwxUu/boot/grub2/device.map
/usr/src/packages/KIWI-oem/oem/SLES_12_SP3_JeOS.x86_64-1.0.0.raw 2>&1]
[ 514s] Jul-03 22:10:39 <3> : Couldn't install grub2 on
/usr/src/packages/KIWI-oem/oem/SLES_12_SP3_JeOS.x86_64-1.0.0.raw:
/usr/sbin/grub2-bios-setup: error: cannot find a device for
/tmp/kiwiboot.ZcwxUu/boot/grub2/i386-pc (is /dev mounted?).
[ 514s] Jul-03 22:10:39 <1> : EXEC [sync]
[ 514s] Jul-03 22:10:39 <1> : EXEC [sync]
[ 514s] Jul-03 22:10:39 <1> : EXEC [umount /tmp/kiwiboot.LZ3lKV 2>&1]
[ 514s] Jul-03 22:10:39 <1> : EXEC [kpartx -sd /dev/loop0 2>&1]
[ 515s] Jul-03 22:10:40 <1> : EXEC [losetup -d /dev/loop0 2>&1]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <1> : EXEC [rm -rf /tmp/kiwiboot.ZcwxUu 2>&1]
[ 515s] Jul-03 22:10:40 <1> : EXEC [rm -rf /tmp/kiwiloop.r3dvbE 2>&1]
[ 515s] Jul-03 22:10:40 <1> : EXEC [rm -rf /tmp/kiwiboot.LZ3lKV 2>&1]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <1> : EXEC [sync]
[ 515s] Jul-03 22:10:40 <3> : KIWI exited with error(s)
[ 515s] Jul-03 22:10:40 <1> : Closing session with ecode: 1
[ 515s] Jul-03 22:10:40 <1> : EXEC [rm -rf
/usr/src/packages/KIWI-oem/oem/boot-VMX.TGzh42 2>&1]
[ 515s]
[ 515s] g570.system failed "build config.kiwi" at Wed Jul 3 22:10:40 UTC 2019.
[ 515s]

The buildroot was: /var/tmp/build-root/images-x86_64
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >