Mailinglist Archive: opensuse-buildservice (66 mails)

< Previous Next >
Re: [opensuse-buildservice] Could this bug be the result of bad mirror handling?
Hi there,

On Sun, 06 Jan 2019, 12:01:30 +0100, Dave Plater wrote:
Hi, myself and others have had strange random errors with home project's
repositories. see:
https://bugzilla.opensuse.org/show_bug.cgi?id=1112615
This has caused me lot's of frustration in bug fixing, in one case I
couldn't understand why the reporter was still having problems with the
fixed package until I discovered that the reporter wasn't getting the
current package but an old one left behind after I had deleted and re
branched said package.

I read the referenced boo, and now I am not sure if what I see, "works as
designed" or if there is a bug.

Anyway, when thunderbird60 from Wolfgang Rosenauer's "mozilla" project
didn't build for openSUSE_Leap_42.3, I branched it into my subproject
home:manfred-h:mozilla and worked on it. When it finally built, I
submitted it back to Wolfgang and disabled build and publish in my repo.
However, there are still packages available at


<http://download.opensuse.org/repositories/home:/manfred-h:/mozilla/openSUSE_Leap_42.3/x86_64/>

which I don't know how to finally get rid of (i.e. deleted). And yes,
there are no binaries available via osc:

$ osc ls -b home:manfred-h:mozilla thunderbird60
openSUSE_Leap_42.3/x86_64
openSUSE_Leap_15.0/x86_64

FWIW, I already ran "osc wipebinaries" for my home project and its
subprojects.

What can I do to ensure that such packages get actually removed from doo
and its mirrors?

Thanks
Dave P

TIA, cheers.

l8er
manfred
< Previous Next >
References