Mailinglist Archive: opensuse-buildservice (48 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: The repository setup is broken...
Hi Roger,

what I see on the end of the project config of the science project is:

...

%if %suse_version == 1315
%if %opensuse_bs == 1
# openSUSE:42
%else
# SLE12
%define sles_version 12
Prefer: java-1_7_0-openjdk-headless
Macros:
%sles_version 12
:Macros
%endif
# openSUSE 13.2
%if %suse_version == 1320
Prefer: java-1_8_0-openjdk-devel
%endif
# opsnSUSE Factory
%if %suse_version >= 1321
Prefer: java-1_8_0-openjdk-devel
%endif

Looks like that an %endif is missing for the first %if - maybe that
cause your problems. So you should contact the maintainers of the
science project.


Am 13.10.18 um 15:51 schrieb Roger Oberholtzer:
Perhaps a more concrete thing.

I m trying to build the Point Cloud library (PCL) here:

https://build.opensuse.org/package/show/home:rogeroberholtzer/pcl

I need two packages: FLANN and METSLIB. For Tumbleweed, these seem to
be in the base repo. For Factory, 15.0 and 42.3, these are in science.
When I add science, I get the error as originally described:

The repository setup is broken, build or publish not possible.

So all builds are blocked for these targets until i remove science.
But then the package requirements cannot be met. I do not want to make
a local copy of thee packages as that just hides the problem...


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >