Mailinglist Archive: opensuse-buildservice (65 mails)

< Previous Next >
[opensuse-buildservice] Re: How to enforce specific system library for a specific package
  • From: Andreas Schwab <schwab@xxxxxxx>
  • Date: Thu, 20 Sep 2018 13:11:24 +0200
  • Message-id: <mvmworge84j.fsf@suse.de>
On Sep 20 2018, "Dr. Werner Fink" <werner@xxxxxxx> wrote:

I'm currently build bash 5.0 beta as well as readline 8.0 beta.
As readline does build local with osc as well as on the OBS and
also bash with --prefer-pkgs $PWD/binaries where the readline
package are stored ... but the build on the OBS results in

nothing provides readline-devel = 8.0

is there any way in prjconf of the repository shell to enforce
that the package readline-devel with version 8.0 will be installed
but oly for the pacakge bash with version 5.0

There can only be a single version of a package in a repository. If you
need more than one version you need to use different names.

Andreas.

--
Andreas Schwab, SUSE Labs, schwab@xxxxxxx
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References