Mailinglist Archive: opensuse-buildservice (65 mails)

< Previous Next >
[opensuse-buildservice] Ubuntu dependencies
  • From: Ansgar Esztermann-Kirchner <aeszter@xxxxxxxxxxxxx>
  • Date: Mon, 10 Sep 2018 09:34:06 +0200
  • Message-id: <20180910073406.GA12896@aeszter.mpibpc.intern>
Hello List,

I'm trying to build the cfengine package for Ubuntu. I've followed the
tutorial/howto from the Wiki, and things worked out as far as starting
the build process proper. However, I've been unable to provide a
certain requirement. I've edited debian.control to contain this line:
Build-Depends: debhelper (>= 8.0.0), liblmdb-dev

Now, the build terminates early because the dependency on liblmdb-dev
is unmet. For RPM builds, merely stating the dependency is enough to
draw in the necessary package (if it's in the correct repo), so I
assumed the problem lies in the fact that lmdb is a "Universe"
package (I assume this means it's not in the standard repo, but
somewhere else). So I've used a _service file to recompile lmdb in the
same OBS project I'm using for my package-to-be, but to no avail: OBS
still complains about
[ 11s] dpkg-checkbuilddeps: error: Unmet build dependencies: liblmdb-dev

What am I doing wrong?


Thanks,

A.
--
Ansgar Esztermann
Sysadmin
http://www.mpibpc.mpg.de/grubmueller/esztermann
< Previous Next >
This Thread
  • No further messages