Mailinglist Archive: opensuse-buildservice (81 mails)

< Previous Next >
Re: [opensuse-buildservice] using openSUSE:Tools breaks pkgs
On Mittwoch, 21. Februar 2018, 09:17:29 CET wrote Olaf Hering:
I switched a few packages from tar_scm to obs_scm. This brings the pkgs into
state "unresolvable". To fix that I added openSUSE:Tools into the path, the
repository looks now like this:

<repository name="SLE_12">
<path project="SUSE:SLE-12-SP3:Update" repository="standard"/>
<path project="openSUSE:Tools" repository="SLE_12_SP3"/>
<arch>x86_64</arch>
</repository>

Once I did that I noticed that each and every package in the prj was
republished. One of the reasons is: an outdated systemd-rpm-macros.rpm is
used during build. It should have been 3-10.6.1, but infact 3-8.374 is used.

Why does "openSUSE:Tools" override the "SUSE:SLE-12-SP3:Update" path? I
thought there is some ordering, the first one wins.

yes, but "standard" is actually empty and you need to follow the path elements
for each
product channel. So it must be last.

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany




--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References