Mailinglist Archive: opensuse-buildservice (81 mails)

< Previous Next >
[opensuse-buildservice] cannot build SLES15 kiwi image in OBS #2
Hi there,

now that I figured out which repos to use and which rpms to build by
hand, my kiwi build is stuck again...
Again, I can repdoduce this at my local OBS instance and also on
build.opensuse.org.

Something with creating lvs is broken.
This config works fine on SLES12 kiwi builds.

<systemdisk name='local'>
<volume name='@root' size='10240M'/>
</systemdisk>

Sadly I also did not find any recent examples for a LVM scenario in any
of you git repos (except for the schema docs, which tell me that this is
right).

https://build.opensuse.org/package/show/home:waldt:branches:SUSE:Templates:Images:SLE-15/kiwi-SLES15-xen
https://build.opensuse.org/package/live_build_log/home:waldt:branches:SUSE:Templates:Images:SLE-15/kiwi-SLES15-xen/images/x86_64

[ 237s] [ DEBUG ]: 09:19:55 | EXEC: [pvcreate /dev/mapper/loop0p3]
[ 237s] [ DEBUG ]: 09:19:55 | EXEC: [vgcreate local /dev/mapper/loop0p3]
[ 237s] [ INFO ]: 09:19:55 | Creating volumes(ext4)
[ 237s] [ DEBUG ]: 09:19:55 | EXEC: [du -s --apparent-size
--block-size 1 /usr/src/packages/KIWI-oem/build/image-root]
[ 238s] [ DEBUG ]: 09:19:55 | EXEC: [bash -c find
/usr/src/packages/KIWI-oem/build/image-root | wc -l]
[ 238s] [ INFO ]: 09:19:55 | --> volume LVRoot with 2680 MB
[ 238s] [ DEBUG ]: 09:19:55 | EXEC: [lvcreate -L 2680 -n LVRoot local]
[ 238s] [ DEBUG ]: 09:19:55 | EXEC: Failed with stderr: WARNING:
Failed to connect to lvmetad. Falling back to device scanning.
[ 238s] /dev/local/LVRoot: not found: device not cleared
[ 238s] Aborting. Failed to wipe start of new LV.
[ 238s] , stdout: (no output on stdout)
[ 238s] [ ERROR ]: 09:19:55 | KiwiCommandError: lvcreate: stderr:
WARNING: Failed to connect to lvmetad. Falling back to device scanning.
[ 238s] /dev/local/LVRoot: not found: device not cleared
[ 238s] Aborting. Failed to wipe start of new LV.
[ 238s] , stdout: (no output on stdout)

Cheers,

--
Eike Waldt
Linux Consultant & Trainer
Tel.: +49-175-7241189
Mail: waldt@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

< Previous Next >
Follow Ups