Mailinglist Archive: opensuse-buildservice (82 mails)

< Previous Next >
[opensuse-buildservice] [Ping] Look to correct repository in the function 'expandsearchpath'
Hello.
Ping.
On 10/05/2017 09:00 AM, Oleg Ogurtsov wrote:
Hello.
I offer a patch for the review.

The simple description:
The project configuration can have several paths, for example with prebuild packets.
RPM-packets search for build root is performed only on the last path.
And the build can end with an error 'getbinaries: missing packages:'.

Also I not sure about processing of remote url.


The detail description below. The test configuration have 3 projects:
The Prebuilds project configuration:
<repository name="x86_64">
<arch>x86_64</arch>
</repository>
<repository name="arm">
<arch>armv7l</arch>
</repository>
The B project configuration:
<repository name="x86_64">
<path project="Prebuilds" repository="x86_64"/>
<arch>x86_64</arch>
</repository>
<repository name="arm">
<path project="Prebuilds" repository="arm"/>
<arch>armv7l</arch>
</repository>
The A project configuration:
<repository name="standard">
<path project="B" repository="arm"/>
<path project="B" repository="x86_64"/>
<arch>x86_64</arch>
<arch>armv7l</arch>
</repository>
Packages in both projects can be built after wiping A and B projects.
But the packages build in the A project for armv7l architecture fails with error 'getbinaries: missing packages:', because it can not find prebuilded packages.
--
Best regards,
Oleg Ogurtsov.

Samsung R&D Institute Russia,
e-mail: o.ogurtsov@xxxxxxxxxxx
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages