Mailinglist Archive: opensuse-buildservice (54 mails)

< Previous Next >
Re: [opensuse-buildservice] AppImage build with old g++ fails
On 24 October 2017 at 07:46, Frank Kunz <mailinglists@xxxxxxxxxxxxxxxxx> wrote:
How to get a newer compiler version into use for AppImage build?

Have you tried adding gcc5-c++ as a BuildRequires? You'll then need to
tell the Makefile to run g++-5 somehow. Depending on how the Makefile
is written, this could either involve setting an environment variable
(if it's written properly) or writing a patch to change the g++
command (if written poorly).

--
- Karl Cheng (Qantas94Heavy)
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References