Mailinglist Archive: opensuse-buildservice (73 mails)

< Previous Next >
[opensuse-buildservice] Broken dependency solver
  • From: Andreas Schwab <schwab@xxxxxxx>
  • Date: Thu, 06 Jul 2017 12:03:33 +0200
  • Message-id: <mvm1sptg9vu.fsf@suse.de>
osc buildinfo says that rubygem-gem2rpm depends on ruby2.4, but when
the package is built it is missing:

$ osc buildinfo openSUSE:Factory:ARM rubygem-gem2rpm standard armv7l | grep
ruby2.4
<bdep name="ruby2.4" version="2.4.1" release="2.1" arch="armv7hl"
project="openSUSE:Factory:ARM" repository="standard" />
<bdep name="libruby2_4-2_4" version="2.4.1" release="2.1" arch="armv7hl"
project="openSUSE:Factory:ARM" repository="standard" />
<bdep name="ruby2.4-stdlib" version="2.4.1" release="2.1" arch="armv7hl"
project="openSUSE:Factory:ARM" repository="standard" />
$ osc rblt openSUSE:Factory:ARM rubygem-gem2rpm standard armv7l | grep -B2
ruby2.4
[ 23s] + exec rpmbuild -ba --define '_srcdefattr (-,root,root)' --nosignature
--target=armv7hl-suse-linux --define '_build_create_debug 1' --define 'disturl
obs://build.opensuse.org/openSUSE:Factory:ARM/standard/7623b38fee0ac8c1f14ccb2306c23898-rubygem-gem2rpm'
/home/abuild/rpmbuild/SOURCES/rubygem-gem2rpm.spec
[ 23s] error: Failed build dependencies:
[ 23s] ruby2.4 is needed by rubygem-gem2rpm-0.10.1-11.6.armv7hl

Andreas.

--
Andreas Schwab, SUSE Labs, schwab@xxxxxxx
GPG Key fingerprint = 0196 BAD8 1CE9 1970 F4BE 1748 E4D4 88E3 0EEA B9D7
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages