Mailinglist Archive: opensuse-buildservice (176 mails)

< Previous Next >
Re: [opensuse-buildservice] Build RPM with GCC6

On Friday 2017-03-31 13:46, Till Dörges wrote:
--- snip ---
unresolvable: conflict for provider of libgcc_s1 &gt;= 6.1.1+r238085-1.12
needed by
gcc6, (provider libgcc_s1-gcc6 is conflicted by installed libgcc_s1)
--- snip ---

Is maybe this line from the prjconf what's causing the problem?

Preinstall: libbz2-1 libgcc_s1 m4 libncurses5 pam

Or what do I have to do to build with gcc6 in OBS for openSUSE Leap 42.2?

<repository name="openSUSE_Leap_42.2">
<path project="devel:gcc" repository="openSUSE_Leap_42.2">
...
</repository>

&&

BuildRequires: gcc6-c++

&&

%build
export CXX=g++-6
%configure. ..

like before.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References