Mailinglist Archive: opensuse-buildservice (176 mails)

< Previous Next >
Re: [opensuse-buildservice] Beta One of Open Build Service 2.8 Released
On Montag, 6. März 2017, 16:25:55 CET wrote Carsten Höger:
Hi Adrian,

On 6 Mar 2017, at 16:12 , Adrian Schröter <adrian@xxxxxxx> wrote:

I just did a quick test and updated a fresh installed 2.7 to 2.8 following

https://github.com/openSUSE/open-build-service/blob/2.8/dist/README.UPDATERS

Thanks a lot for testing!

Did you also test the migration with your production data?

No, that was a fresh installation if 2.7 with a simple test project created.
Production is still on 2.6...

would be great if you can test it (using some snapshot)

After the update, the webui just presents an error message:

We're sorry, but something went wrong.

We've been notified about this issue and we'll take a look at it shortly.


This is in the logs:

==> passenger.log <==
App 5273 stdout:
App 5273 stdout:
[ 2017-03-06 15:55:07.0824 4049/7f6441445700
age/Cor/App/Implementation.cpp:304 ]: Could not spawn process for
application /srv/www/obs/api: An error occurred while starting up the
preloader.
Error ID: c039a13c
Error details saved to: /var/run/passenger/passenger-error-I1tr9E.html
Message from application: cannot load such file --
phusion_passenger/platform_info/ruby (LoadError)
/usr/lib64/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:127:in `require'
...

Did you change the passenger config to use ruby2.4 ?
(/etc/apache2/conf.d/mod_passenger.conf)


That’s it!

PassengerRuby "/usr/bin/ruby.ruby2.4”


That should definitely go into
https://github.com/openSUSE/open-build-service/blob/2.8/dist/README.UPDATERS

Yep, will do so ...

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >