Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
[opensuse-buildservice] Problem with DoD Deb repository for ARM architecture
All,

I'm trying to build debian packages for the ARM architecture and I
believe I have missed some configuration setup that needs to be done. I
have read everything I can find in the user manuals, online web pages
etc. and I haven't been able to get things working.

I can build debian repositories for the Intel architectures using a
local OBS instance of a project leveraging the public OBS:

<repository name="deb">
<download arch="x86_64"
url="http://ftp.de.debian.org/debian/jessie-updates/main"; repotype="deb"/>
<download arch="i586"
url="http://ftp.de.debian.org/debian/jessie-updates/main"; repotype="deb"/>
<path project="openSUSE.org:Debian:8.0" repository="standard"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>

Since the Debian 8.0 project and repository doesn't provide the options
to build aarch64, armv7l I thought the best approach was to create an
identical project on my local OBS instance then work on the ARM build. I
copied the project configuration and meta data from the
openSUSE.org:Debian:8.0 without an issue. Then I triggered a rebuild of
the package and the UI said the build was finished but the log contains.

"404 remote error: remote error Not Found"

I think there is more I need to do to configure the repository but I'm
not sure how to do that.

I'm thinking a similar change is needed for the arm portions and it's
not clear how the architectures map to the Debian names.

Regards,

Steve

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages