Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'
Am 17.02.2017 um 12:01 schrieb Till Dörges:


What is wrong/missing in our setup so that x86_64 builds are fine, but i586
build
give 'unresolvable' with either 'Have choice for i586' or 'Nothing
provides'?


--- snip ---
<project name="P">
<title>...
<description>...
<person userid="Admin" role="maintainer"/>
<repository name="openSUSE_13.1">
<path project="openSUSE.org:13.1" repository="standard"/>
<path project="openSUSE.org:13.1:Update" repository="standard"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>
</project>
--- snap ---

FTR, builds for both i586 and x86_64 RPMs work if I change the above config as
follows, i.e. if I remove the "openSUSE.org:13.1:Update" line:

--- snip ---
<repository name="openSUSE_13.1">
<path project="openSUSE.org:13.1" repository="standard"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
--- snap ---


I still would like to understand why I can't use *both* "openSUSE.org:13.1" and
"openSUSE.org:13.1:Update" for i586, but at least it seems to be working.


Regards -- Till
--
Dipl.-Inform. Till Dörges doerges@xxxxxxxxxxxx
Tel. +49 - 40 - 244 2407 - 14
Fax +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >