Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
Re: [opensuse-buildservice] JFYI, build.o.o is switching to createrepo_c
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Fri, 17 Feb 2017 12:41:49 +0100
  • Message-id: <1531195.kkLaX5KMtv@xrated>
[Send this out yesterday, but the list seems to block HTML bodies (without
giving a reason other than "because of an access rule"), even if an alternate
text body is available..]

Hi Adrian,

On Donnerstag, 16. Februar 2017 13:51:28 Adrian Schröter wrote:
JFYI,

We are switching to use createrepo_c (and modifyrepo_c) for
published repositories.

Nobody should notice a difference, but just in case you are
wondering about some change :)

Maybe related, maybe not: I had some builds running during the switch, and an
installation of those packages resulted in:

Retrieving package postgresql-9.6-1.1.noarch

(18/25), 4.0 KiB ( 83 B unpacked)
Retrieving: postgresql-9.6-1.1.noarch.rpm
........................................................................[done]

Warning: Digest verification failed for file 'postgresql-9.6-1.1.noarch.rpm'
[/var/cache/zypp/packages/home_frispete_database/noarch/postgresql-9.6-1.1.noarch.rpm]

expected a2a291348bb1d1714422a383cad681828810e334475e032e6ca757f49b5beb5e
but got 3168c306cab0125bdc3b81657ddfc6fda0c66a34a14661bfbc46aebbd0b7a18a

Accepting packages with wrong checksums can lead to a corrupted system and in
extreme cases even to a system compromise.

However if you made certain that the file with checksum '3168..' is secure,
correct
and should be used within this operation, enter the first 4 characters of the
checksum
to unblock using this file on your own risk. Empty input will discard the
file.

Unblock or discard? [3168/? shows all options] (discard): 3168
Package postgresql-9.6-1.1 seems to be corrupted during transfer. Do you want
to retry retrieval?
Abort, retry, ignore? [a/r/i] (a): i

It was 4 packages affected:
postgresql-docs-9.6-1.1.noarch.rpm
postgresql-9.6-1.1.noarch.rpm
postgresql-server-9.6-1.1.noarch.rpm
postgresql-contrib-9.6-1.1.noarch.rpm

Hmm, all dummy packages are affected. Smells like something else is wrong
here.

Pete
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References