Mailinglist Archive: opensuse-buildservice (90 mails)

< Previous Next >
[opensuse-buildservice] OBS 2.7: Packages are unresolvable 'Have choice for i586' or 'Nothing provides'
Hello all,

I just upgraded a private OBS instance from 2.6 to 2.7. The openSUSE 13.1 update
repository was a local repository under 2.6 and was converted to a download on
demand
repository for 2.7.


I have configured a project, roughly like so:

--- snip ---
<project name="P">
<title>T</title>
[...]
<repository name="openSUSE_13.1">
<path project="openSUSE.org:13.1" repository="standard"/>
<path project="openSUSE.org:13.1:Update" repository="standard"/>
<arch>i586</arch>
<arch>x86_64</arch>
</repository>
</project>
--- snap ---

Unfortunately I get 'unresolvable' for all i586 packages. The tool tip shows
something like "Have choice for libelf.so.1 needed bei rpm: libelf1
libelf1-32-bit, ...."

x86_64 is building fine.


If I change the order of the <path> entries the state still stays
'unresolvable' for
all i586 packages. But the tool tips change to "Nothing provides
libpopt.so.0()(64bit) needed by rpm-build, ...."

Again, x86_64 is building fine.


The repositories openSUSE.org:13.1 and openSUSE.org:13.1:Update look like this:

--- snip ---
<project name="openSUSE.org:13.1">
<title>openSUSE 13.1 (lokal)</title>
<description>D</description>
<person userid="Admin" role="bugowner"/>
<person userid="Admin" role="maintainer"/>
<publish>
<disable/>
</publish>
<repository name="standard">
<arch>i586</arch>
<arch>x86_64</arch>
</repository>
</project>

<project name="openSUSE.org:13.1:Update" kind="maintenance_release">
<title>openSUSE 13.1 Updates (DoD)</title>
<description>D</description>
<link project="openSUSE.org:13.1"/>
<person userid="Admin" role="bugowner"/>
<person userid="Admin" role="maintainer"/>
<publish>
<disable/>
</publish>
<repository name="standard">
<download arch="x86_64"
url="http://internal.host/opensuse/live/update/13.1/";
repotype="rpmmd"/>
<download arch="i586" url="http://internal.host/opensuse/live/update/13.1/";
repotype="rpmmd"/>
<arch>x86_64</arch>
<arch>i586</arch>
</repository>
</project>
--- snap ---


Obviously something is wrong but I have no idea what and where to debug next.


Any hint would be greatly appreciated!


Thanks and regards -- Till
--
Dipl.-Inform. Till Dörges doerges@xxxxxxxxxxxx
PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups