Mailinglist Archive: opensuse-buildservice (177 mails)

< Previous Next >
Re: [opensuse-buildservice] Publishing Leap 42.2 packages
On Mon, 2016-12-05 at 11:11 +0100, Szőts Ákos wrote:
2016-12-05 10:41 GMT+01:00 Scott Bahling <sbahling@xxxxxxxx>:
On Fri, 2016-12-02 at 12:14 +0100, Szőts Ákos wrote:
Dear list members,

I need some core packages (e.g. GnuTLS) for some of my Leap 42.2
home:
packages but unfortunately I don't see them published [1]. I'd
like to
ask if I've overlooked something or is there some time until
they're
held back?

They are published, as well as available for build but your packages
require gnutls version >= 3.3 where Leap 42.2 has version 3.2.15.

-Scott

When you search for "gnutls" on software.opensuse.org [1], it's not
listed as an official package in contrast to Leap 42.1 or Tumbleweed.
That's why I thought packages are not published. You can also try the
same experiment with "aaa_base" [2].

That is a bug in software.opensuse.org. Leap 42.2 is definitely
published:

http://download.opensuse.org/distribution/leap/42.2/repo/oss/suse/x86_64
/gnutls-3.2.15-7.5.x86_64.rpm

http://download.opensuse.org/distribution/leap/42.2/repo/oss/suse/x86_64
/aaa_base-13.2+git20140911.61c1681-23.1.x86_64.rpm


But that's unrelated to your issue of being able to build against Leap
42.2 in OBS. A package does not need to be published in order to use it
for building. What is important is the "Use for Build Flag" which is
set.

Best Regards,

Scott
< Previous Next >