Mailinglist Archive: opensuse-buildservice (124 mails)

< Previous Next >
Re: [opensuse-buildservice] scheduler ignores package version dependency
On Thu, Nov 24, 2016 at 08:18:48AM +0100, Adrian Schröter wrote:
On Mittwoch, 23. November 2016, 23:27:13 CET wrote Marcus Hüwe:
On 2016-11-23 20:31:05 +0100, Tom M. wrote:
I'm maintaining a package
https://build.opensuse.org/package/show/home:derselbst:anmp/anmp that
requires cmake >= 3.1.0 for building successfully.
This version dependency is respected and the scheduler correctly notes
"unresolvable" if no cmake >= 3.1.0 is available for a repository (as
it is the case for openSUSE_13.2). For Mageia5 however, the scheduler
does not complain that he cant meet this dependency and cmake == 3.0.1
gets installed, which breaks the build. Though I would expect that the
scheduler notes "unresolvable" for mageia5.

Is this a bug in OBS or am I missing something?

The Mageia_5 cmake package has an epoch of "1" set (which means
1:3.0.1 > 0:3.1.0 = 3.1.0). You can see this when having a look at the
buildinfo: osc buildinfo home:derselbst:anmp anmp Mageia_5 x86_64

Uh, good spot .... yet another prove that epochs are only moving problems
to the next level :/

I wonder if we should have some flag to ignore epochs ...

No way!

on the other hand
a spec file explizit written for Mageia might rely on it... hm

Just use some %if statements. It's the same as with different
package names.

Cheers,
Michael.

--
Michael Schroeder mls@xxxxxxx
SUSE LINUX GmbH, GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups