Mailinglist Archive: opensuse-buildservice (124 mails)

< Previous Next >
Re: [opensuse-buildservice] 'Ghost' builds from deleted projects
Hi Matt,

The extract file service still exist, but like all other OBS services it
is not longer part of the OBS server project, but in the openSUSE:Tools
project.

Cheers
Karsten

Am 30.08.2016 um 16:57 schrieb Matthew Drobnak:
Cool. That seems to have worked. My other 'stalled' packages were ones
that had constraints on them, and those are building now.

However, I've hit into a much larger problem - it seems that the
extract_file service no longer exists?

What is the correct workflow when cloning from git and extracting dsc /
spec files?

I'd rather not move two versions in one maintenance. We can definitely
schedule a follow-up in a few weeks after to move to 2.7 though.

-Matt

On Tue, 2016-08-30 at 08:12 +0200, Adrian Schröter wrote:
On Montag, 29. August 2016, 21:41:07 CEST wrote Matthew Drobnak:
I'm having an issue where during a deep project scan, it's coming up
with about ~150 packages (after an upgrade to 2.6.10, on 2.5.5 this
would be about 1000) that need to be built..but they seem to stick in
the waiting queue, with about 140 in the blocked queue.

The projects give a 404 when trying to do a rdelete.
For example - trying to delete Project
ProjectA:SubProject:app-4.40.2.asan.0 (another subproject) --

$ osc -A https://obs02.nym2.appnexus.com undelete
ProjectA:SubProject:app-4.40.2.asan.0
Server returned an error: HTTP Error 404: Not Found
&lt;status code="404"&gt;
&lt;summary&gt;project 'ProjectA:SubProject:app-4.40.2.asan.0' already
exists&lt;/summary&gt;
&lt;details&gt;404 project 'ProjectA:SubProject:app-4.40.2.asan.0'
already exists&lt;/details&gt;
&lt;/status&gt;

$ osc -A https://obs02.nym2.appnexus.com rdelete
ProjectA:SubProject:app-4.40.2.asan.0
Server returned an error: HTTP Error 404: Not Found
ProjectA:SubProject:app-4.40.2.asan.0

simple workaround would be to create the project again and
to remove.

How can I delete these items properly? I am trying to resolve this so I
can upgrade our system from 2.5.5 to 2.6.10; we had one too many build
storms, and we are trying to get more current.

Hm, can't you update due to this?

If you update to 2.7, you can use the consistency check we implemented
there. It checks for any difference between api and backend and allows
to fix it...


N�����r��y隊Z)z{.���Wlz��qﮞ˛���m�)z{.��+�:�{Zr�az�'z��j)h���Ǜ�)]���Ǿ� ޮ�^�ˬz�



--
Linux Consultant, Linux Kernel Developer
Tel.: +49-175-7249132
Mail: keil@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups