Mailinglist Archive: opensuse-buildservice (86 mails)

< Previous Next >
Re: [opensuse-buildservice] osc buildinfo is lying

On 08/06/2016 17:04, Andreas Schwab wrote:
osc buildinfo openSUSE:Factory:PowerPC rubygem-gem2rpm standard ppc64
says that ruby2.2 and ruby2.3 will be installed, but when the package is
built ruby2.1 and ruby2.2 are installed. Why?

Andreas.


Andreas,
sorry I did not saw this email, and continued thread on factory-ppc (1)
as I said there, I was able to build rubygem-gem2rpm on a local ppc64le guest
(not in OBS)
And on this same guest as you noted the buildinfo report ruby2.2 and ruby2.3 as
bdep. (2)

I am wondering if we have same result on OBS ppc64le builders.

Would it be possible to execute the same osc buildinfo on either build95
build89 ?
These are two last builders that reported failures for this package (3)
I am not authorised to have a shell access on them.


(1) https://lists.opensuse.org/opensuse-ppc/2016-06/msg00003.html

(2)
=== on my ppc64le guest:
$osc buildinfo openSUSE:Factory:PowerPC rubygem-gem2rpm standard ppc64le |grep
ruby |grep bdep
<bdep name="ruby2.2" version="2.2.5" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="ruby2.3" version="2.3.1" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="libruby2_2-2_2" version="2.2.5" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="ruby-common" version="2.1" release="9.3" arch="noarch"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="ruby2.2-stdlib" version="2.2.5" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="libruby2_3-2_3" version="2.3.1" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
<bdep name="ruby2.3-stdlib" version="2.3.1" release="1.2" arch="ppc64le"
project="openSUSE:Factory:PowerPC" repository="standard" />
===

(3)
===
$osc jobhistory openSUSE:Factory:PowerPC/rubygem-gem2rpm/standard/ppc64le |
tail -n5
2016-04-11 07:26:09 rubygem-gem2rpm source change succeeded 0m 32s
build88:1
2016-04-25 00:21:17 rubygem-gem2rpm new build succeeded 0m 30s
build95:8
2016-04-25 19:09:17 rubygem-gem2rpm meta change succeeded 0m 52s
build88:10
2016-06-07 22:49:24 rubygem-gem2rpm new build failed 0m 35s
build95:5
2016-06-08 14:57:50 rubygem-gem2rpm new build failed 0m 25s
build89:7
===


--
Michel Normand

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References