Mailinglist Archive: opensuse-buildservice (99 mails)

< Previous Next >
Re: [opensuse-buildservice] Fedora Rawhide, please add %fedora_version
On Mittwoch, 16. März 2016, 15:26:04 wrote Ruediger Meier:
On Wednesday 16 March 2016, Adrian Schröter wrote:
On Mittwoch, 16. März 2016, 13:46:09 wrote Ruediger Meier:
On Wednesday 16 March 2016, Adrian Schröter wrote:
On Mittwoch, 16. März 2016, 09:28:07 wrote Ruediger Meier:
On Wednesday 16 March 2016, Adrian Schröter wrote:
On Dienstag, 15. März 2016, 10:44:36 wrote Ruediger Meier:
Hi,

this topic was already discussed on this list. Please
provide %fedora_version for Rawhide.

In case you don't want to maintain this increasing number
just set to 99.

Thanks!

Now I have another issue:

[ 31s] processing recipe /.build-srcdir/atem.spec ...
[ 31s]
init_buildsystem --configdir /.build/configs --cachedir
/var/cache/build /.build-srcdir/atem.spec build rpmlint-Factory
... [ 34s] initializing rpm db...
[ 34s] error: Failed to initialize NSS library

well, the current Rawhide still works for me in openSUSE:Tools.

No, the problem seems to be very new since yesterday:

$ osc rbl -s openSUSE:Tools/build Fedora_Rawhide x86_64 | tail -n
12 initializing rpm db...
error: Failed to initialize NSS library

right, it did still work with my old chroot some hours ago...

build22 failed "build build.spec" at Wed Mar 16 12:35:41 UTC 2016.

### WATCHDOG MARKER START ###
[ 17.666676] SysRq : Power Off
[ 17.673675] reboot: Power down
### WATCHDOG MARKER END ###

build22 failed "build build.spec" at Wed Mar 16 12:35:46 UTC 2016.

So, this looks like a local problem where either the dependencies
of rpm have changed or you do not preinstall the necessary libs
anymore.

Maybe a typical Fedora Problem :)
https://bugzilla.redhat.com/show_bug.cgi?id=1067443#c2

Probably dependencies of one of the preinstalled Rawhide packages
is broken.

yes, but someone needs to debug it. Can you try to do it?

Try it with a local build and trace the system until rpm is able to
start again...

Yes, I've tried already but it's hard because backspace and arrow and
ctrl keys do not work in rawhide chroot.

bash-4.3# rpm -q
error: Failed to initialize NSS library


Maybe just a package split or a new library dependency. We can add
that in preinstall then.

How can I force preinstalling strace locally? Ive tried editing
.osc/_buildconfig-Fedora_Rawhide-x86_64
and osc build --offline, but did not worked.

You can add it in your's project config as preinstall package.

So you can also test if adding a certain package will solve the issue.

--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups