Mailinglist Archive: opensuse-buildservice (138 mails)

< Previous Next >
Re: [opensuse-buildservice] openSUSE Leap 42.1: have choice for libwx_baseu

On Tuesday 2016-02-16 21:38, Matwey V. Kornilov wrote:
At my test project [1] package 'erlang-wx-test' is unresolved for
openSUSE Leap 42.1.
Its requirement erlang-wx has choice for libwx_baseu.

%if 0%{?suse_version} >= 1315
BuildRequires: wxWidgets-devel >= 2.8
%define wx_requires_generator 1
%else

In Leap, >=2.8 is satisfiable by two packages basically
(and wxWidgets-devel is chosen because of a direct match,
while wxWidgets-3_0-devel is only an indirect match).

You should explicitly demand >=3.0 even for Leap,
because the 2.8 package with the generator fuglyness has just too many pain
points.


At the same time, erlang-wx can be installed without conflicts or
choices on freshly installed openSUSE Leap system:

Once the buildrequire choice was made and RPMs are produced, of course you can
install them (in this case).
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References