Mailinglist Archive: opensuse-buildservice (138 mails)

< Previous Next >
Re: [opensuse-buildservice] Failed to setup obs api_production database
On Dienstag, 2. Februar 2016, 11:22:00 CET wrote 黄顺:
Hi,

I am currently trying to setup a local OBS instance( based on Leap 42.1,
using repository OBS:/Server:/Unstable/openSUSE_Leap_42.1).

And all services went up fine, except “obsaipdelayed.service", here is what I
got:

---
---
Icy@linux-dexl:~> sudo systemctl restart obsapidelayed.service
Job for obsapidelayed.service failed. See "systemctl status
obsapidelayed.service" and "journalctl -xn" for details.
Icy@linux-dexl:~> sudo systemctl status obsapidelayed.service
root's password:
obsapidelayed.service - LSB: OBS api delayed jobs
Loaded: loaded (/etc/init.d/obsapidelayed)
Active: failed (Result: exit-code) since Mon 2016-02-01 21:42:28 EST; 8min
ago
Process: 1620 ExecStart=/etc/init.d/obsapidelayed start (code=exited,
status=1/FAILURE)

Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: from
/usr/lib64/ruby/gems/2.3.0/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in
`public_send'
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: from
/usr/lib64/ruby/gems/2.3.0/gems/railties-4.2.5.1/lib/rails/railtie.rb:194:in
`method_missing'
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: from
/srv/www/obs/api/config/environment.rb:30:in `<top (required)>'
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: from
script/delayed_job.api.rb:3:in `require'
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: from
script/delayed_job.api.rb:3:in `<main>’
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: ..failed
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: Starting OBS api clock daemon
clockworkd.clock: pid file: /srv/www/obs/api/tmp/clockworkd.clock.pid
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: clockworkd.clock: output log
file: /srv/www/obs/api/log/clockworkd.clock.output
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: clockworkd.clock: process
with pid 1663 started.
Feb 01 21:42:28 linux-dexl obsapidelayed[1620]: ..done
---



I followed the setup procedures from
https://github.com/openSUSE/open-build-service , and did no special tricking.

So did I do something wrong or is something wrong with the package:
obs-api-2.6.51.git20160201.cac3343-1669.1.noarch.

maybe ... can you check the delayed and production log in /srv/www/obs/log ?

Also, starting it this way:

cd /etc/init.d
./obsapidelayed start

is using the script directly without systemd in between. It
can help to debug things...


--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284
(AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References