Mailinglist Archive: opensuse-buildservice (138 mails)

< Previous Next >
[opensuse-buildservice] wrong baselibs requires
Hi,

I try to build cups with 32bit compatibility packages for SLE11 SP3.
For some unknown reason cups on SLE11 was build without compatibility
packages. So I tried to build the same version with 32bit Support.
The build works fine, but the cups-devel-32bit cannot be installed
without errors, since it has an extra requires for cups-32bit, which is
not provided by any of the sub packages. It should only require
cups-libs-32bit.
the baselibs.conf I tried was:

cups-devel
cups-libs


And with extra stuff:

cups-libs
obsoletes "cups-libs-<targettype> <= <version>"
provides "cups-libs-<targettype> = <version>"
cups-devel
requires -libs-<targettype>
requires "cups-libs-<targettype> = <version>"


But always with the same result of the extra cups-32bit requires.

You can lookup the results in home:kkeil:cups.

Any ideas how to get rid of this extra requires ?


Karsten

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >