Mailinglist Archive: opensuse-buildservice (126 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: strange dependency issue for digikam in KDE:Extra building for openSUSE:13.2:Update
On Tuesday 17 Feb 2015 16:44:00 Malcolm wrote:
On Tue 17 Feb 2015 11:24:01 PM CST, Nico Kruber wrote:
maybe this is a better list to solve the issue below...

btw: if I explicitely set the requirement to libkface-devel >= 14.12,
the dependency is not found at all :(

---------- Forwarded Message ----------

Subject: Re: building KDE:Extra against openSUSE_*:Update repos?
Date: Monday 16 Feb 2015, 14:06:02
From: Nico Kruber <nico.kruber@xxxxxxxxx>
To: opensuse-kde@xxxxxxxxxxxx <opensuse-kde@xxxxxxxxxxxx>

However, can someone explain why the digikam build still pulls
libkface- devel-4.4.0-9.1 instead of libkface-devel-14.12.1-2.1 which
should _both_ be available in 13.2:Update?
https://build.opensuse.org/build/KDE:Extra/openSUSE_13.2/x86_64/digikam/_lo
g

The spec file should be correct in this regard:
%if 0%{?suse_version} > 1310
BuildRequires: libkface-devel
%endif


Regards
Nico
-----------------------------------------

Hi
Use BuildRequires of pkgconfig(libkface) instead.

https://build.opensuse.org/package/binary/openSUSE:13.2:Update/patchinfo.341
5?arch=i586&filename=libkface-devel-14.12.1-2.1.x86_64.rpm&repository=standa
rd

Thanks Malcom,
but unfortunately this leads to the same behaviour...
(it would have been strange, if that worked, and the direct requirement did
not)

btw: the link you provided also proves that "libkface-devel = 14.12.1-2.1" is
provided


Nico
< Previous Next >
References