Mailinglist Archive: opensuse-buildservice (126 mails)

< Previous Next >
[opensuse-buildservice] Re: KDE4 on SLE_12
Hello,

currently the build hangs a bit in kdebase4-workspace.

Where / how I should report bugs in .spec files?

I think I found a bug in the spec file kdebase4-workspace.spec
in openSUSE 13.2 and SLE_12 build.

SLE_12 disables wayland-egl from the changes file:

Mesa.spec:- disable wayland support for sle12, i.e. suse < 1320

%if 0%{?suse_version} >= 1320
BuildRequires: pkgconfig(wayland-client)
BuildRequires: pkgconfig(wayland-server)
%endif

(Here we ahve a small fearute doc != RPM tag, but thats not a real problem)

And then in the openSUSE:13.2 version of kdebase-worksapce
someone has made a typo (I would say)

Instead of 13.3 its 12.3:

Index: kdebase4-workspace.spec
===================================================================
--- kdebase4-workspace.spec (revision 1)
+++ kdebase4-workspace.spec (working copy)
@@ -60,7 +60,7 @@
BuildRequires: pkgconfig(libudev)
BuildRequires: pkgconfig(xcb-keysyms)
# Unlock this when we get weston in Factory
-%if %suse_version > 1230
+%if %suse_version > 1330
BuildRequires: wayland-devel
BuildRequires: pkgconfig(wayland-egl)
%endif

Where should I post these changes?

regards,

Martin
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups