Mailinglist Archive: opensuse-buildservice (132 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS gateway hiccup?
On 20.01.2015 08:31, Adrian Schröter wrote:
On Montag, 19. Januar 2015, 16:27:12 wrote Ralf Lang:
I get the following kind of error when accessing OBS for "osc build" or
"osc ci".

Building groupware-image-13.2.kiwi for images/x86_64
Getting buildinfo from server and store to
/srv/obs/isv:B1-Systems:Horde5:opensuse-appliance/groupware-image/.osc/_buildinfo-images-x86_64.xml
Server returned an error: HTTP Error 502: Bad Gateway

it is often a timeout error. And it is quite like here the case due to the
stressful calculation of kiwi images (many package deps to solve).

However, it works often when you repeat it after some time, because the
result becomes cached.

How long does it take until you get the error?


It takes roughly 10 minutes.

Getting buildinfo from server and store to
/srv/obs/isv:B1-Systems:Horde5:opensuse-appliance/groupware-image/.osc/_buildinfo-images-x86_64.xml

^[[HServer returned an error: HTTP Error 502: Bad Gateway





Request:
https://api.opensuse.org/build/isv:B1-Systems:Horde5:opensuse-appliance/images/x86_64/groupware-image/_buildinfo

Headers:


content-language: en


transfer-encoding: chunked


accept-ranges: bytes


strict-transport-security: max-age=31536000


vary: accept-language,accept-charset


server: Apache/2.2.12 (Linux/SUSE)


connection: close


date: Tue, 20 Jan 2015 08:38:23 GMT


content-type: text/html; charset=iso-8859-1





real 10m0.923s


user 0m0.286s


sys 0m0.046s

--
Ralf Lang
Linux Consultant / Developer
Tel.: +49-170-6381563
Mail: lang@xxxxxxxxxxxxx
B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537



< Previous Next >
Follow Ups