Mailinglist Archive: opensuse-buildservice (132 mails)

< Previous Next >
[opensuse-buildservice] run-test.sh failure with fontconfig build
Hello folks,

I am trying to build fontconfig for OpenSUSE 13.2. I am using an unmodified fontconfig-2.11.1 package that I branched from the fontconfig build at openSUSE:13.2. I haven't made any changes whatsoever, however, the build always fails.

The test-suite.log can be viewedhere:

http://dickens.com/download/test-suite.log

The last 40 lines of the build.log, where the errors are, can be viewed here:

http://dickens.com/download/tail_-n40-build.log

The entire build log can be viewed here:

http://dickens.com/download/build.log

I don't understand what's going on since this exact same package appears to build just fine at:

https://build.opensuse.org/package/show/openSUSE:13.2/fontconfig

My fontconfig-2.11.1 package, which has not been modifed since I branched it, is here:

https://build.opensuse.org/package/show/home:gldickens3:Microshaft/fontconfig-2.11.1

The reason given for the build failure in test-suite.log is: "*** output is in 'out', expected output in 'out.expected'".

I did find an old bug report of a very similar problem and test-suite.log content here:

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=63329

However, I can't believe that is my problem since that bug has been fixed ***and*** since the package builds just fine at the official OpenSUSE repo at OpenSUSE:13.2/fontconfig.

Could somebody please give me some tips on how to resolve this?

Thanks,

Gordon





--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages