Mailinglist Archive: opensuse-buildservice (116 mails)

< Previous Next >
Re: [opensuse-buildservice] Using non-distro packages as BuildRequires
On Tue, Aug 12, 2014 at 02:38:57AM -0600, Rashmi Ranjan Mohanty wrote:
Hi,

I want to use jdk package from Sun/Oracle to build some package in OBS for
SLE11 SP2 distro. Is it possible to do that ? If yes, how to do it ?
I remember this was possible in autobuild using --preferred option or some
option like that.

BuildRequires: java-1_6_0-openjdk-devel
or
BuildRequires: java-1_7_0-openjdk-devel

not working for you that uses the OpenJDK in SLES 11 SP2?

Or try java-1_7_0-ibm.

Otherwise you need to inject this RPM yourself, e.g. build a java package in
your home project.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >