Mailinglist Archive: opensuse-buildservice (111 mails)

< Previous Next >
[opensuse-buildservice] OBS Appliance stilll stall doing build
Hello I still have a problem with our OBS Appliance.
But I have come a little further. I now know that if I try this:

/usr/bin/qemu-kvm -no-reboot -nographic -vga none -net none -cpu host -kernel
/boot/vmlinuz -initrd /boot/initrd -append root=/dev/sda panic=1 quiet
no-kvmclock nmi_watchdog=0 rw rd.driver.pre=binfmt_misc elevator=noop
console=ttyS0 init=/.build/build -m 256 -drive
file=/var/cache/obs/worker/root_8/root,if=none,id=disk,serial=0,cache=unsafe
-device ide-hd,drive=disk -drive
file=/var/cache/obs/worker/root_8.swap,if=none,id=swap,serial=1,cache=unsafe
-device ide-hd,drive=swap -smp 1

I get to this point
[ 0.075731] NET: Registered protocol family 2
[ 0.076112] TCP established hash table entries: 2048 (order: 3, 32768 bytes)
[ 0.076611] TCP bind hash table entries: 2048 (order: 3, 32768 bytes)
[ 0.077067] TCP: Hash tables configured (established 2048 bind 2048)
[ 0.077514] TCP: reno registered
[ 0.077749] UDP hash table entries: 256 (order: 1, 8192 bytes)
[ 0.078164] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[ 0.078626] NET: Registered protocol family 1
[ 0.078948] pci 0000:00:00.0: Limiting direct PCI/PCI transfers
[ 0.079369] pci 0000:00:01.0: PIIX3: Enabling Passive Release
[ 0.079776] pci 0000:00:01.0: Activating ISA DMA hang workarounds
[ 0.080249] Unpacking initramfs...
and qemu-kvm thread stalls for 8.5 hours and then terminates.

But if I bump the command up to use -m 512 instead I get passed this but get this:
[ 0.374929] Waiting for device /dev/sda1 to settle...
[ 2.377787] Waiting for device /dev/sda1 to settle...
[ 4.385698] Waiting for device /dev/sda1 to settle...
[ 6.393584] Waiting for device /dev/sda1 to settle...
[ 0.340756] Including oem partition info file
[ 0.349662] Searching for boot device...
[ 0.353829] Found boot device: /dev/sda
[ 0.371520] Filesystem of OEM system is: unknown -> /dev/sda1
[ 0.374929] Waiting for device /dev/sda1 to settle...
[ 2.377787] Waiting for device /dev/sda1 to settle...
[ 4.385698] Waiting for device /dev/sda1 to settle...
[ 6.393584] Waiting for device /dev/sda1 to settle...
[ 8.417719] /sbin/init no such file or not executable
[ 8.418671] rebootException: reboot in 120 sec...


Can anyone help me on from this point because this is actually the only blockade for me now (I hope).

Best Regards
Lars Nielsen

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups