Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
Re: [opensuse-buildservice] krb5 in RHEL 6 i586 makes use of an older (1.8.2) version than x86_64 (1.9)
Hi,

On Fri, Jun 13, 2014 at 04:07:03PM +0200, Lars Müller wrote:

Samba builds for RHEL 6 i586 are failing as the included krb5 version is
too old. See
https://build.opensuse.org/package/live_build_log/network:samba:STABLE/samba/RHEL_6/i586

Or in short and for the record:
[ 288s] ERROR: MIT krb5 build requires at least 1.9.0. Kerberos 5
release 1.8.2 is found and cannot be used
[ 288s] ERROR: You may try to build with embedded Heimdal Kerebros by
not specifying --with-system-mitkrb5
[ 288s] error: Bad exit status from /var/tmp/rpm-tmp.cT5QVH (%build)

But this happens only to the i586 flavour which has krb5 1.8.2. While
RHEL 6 x86_64 as CentOS 6 i586 and x86_64 are utilizing version 1.9.

Do we need to built a cloned krb5 for RHEL 6 i586 only or is this a
generic OBS import/ setup issue?

To see how it looks on the real media I've downloaded all RHEL Server 6
i386 ISO images. The available krb5-libs versions are the following:

RHEL i386 ISO krb5-libs rpm release

rhel-server-6.0-i386-dvd.iso 1.8.2 3
rhel-server-6.1-i386-dvd.iso 1.9 9
rhel-server-6.2-i386-dvd.iso 1.9 22
rhel-server-6.3-i386-dvd.iso 1.9 33
rhel-server-6.4-i386-dvd.iso 1.10.3 10
rhel-server-6.5-i386-dvd.iso 1.10.3 10

Therefore it looks like the import of RHEL 6 into the OBS isn't at a
consistent state if you compare the i586 with the x86_64 architecture.

The i568 arch is at level 6.0 while x86_64 is at 6.3. Can both versions
please get aligned at 6.3? Or even better bumped to the 6.5 level?

Cheers,

Lars
--
Lars Müller [ˈlaː(r)z ˈmʏlɐ]
Samba Team + SUSE Labs
SUSE Linux, Maxfeldstraße 5, 90409 Nürnberg, Germany
< Previous Next >
Follow Ups
References