Mailinglist Archive: opensuse-buildservice (166 mails)

< Previous Next >
[opensuse-buildservice] delete a project and packages
I branched a package by mistake in the web interface.

It created a new subproject under my home project.

Now I can't delete either the package or the subproject, either via the delete links in the web ui or by osc rdelete.

What I tried:

* On the package summary page in the web ui,

https://build.opensuse.org/package/show/home:aljex:branches:utilities/byobu

there is a link that says "delete package".

It just returned a 500 internal server error.

* On the subproject summary page in the web ui,
https://build.opensuse.org/project/show/home:aljex:branches:utilities

there is a link that says "delete project"

It just returned a 500 internal server error.

* "osc deletepac" says the command is obsolete and to use delete or rdelete.

* "osc rdelete home:aljex:branches:utilities byobu"
puts me in a vim editor with no explanation, but says something about a log entry when I esc:q! out of it, so I tried again and wrote "created by mistake" and esc:x , and that returns:

"/tmp/osc-commitmsgYCbCUa.diff" 3L, 68C written
Server returned an error: HTTP Error 500: Internal Server Error

* "osc rdelete -r home:aljex:branches:utilities"
does the same as above.

So how do I delete this package and the subproject project it's in?

In the mean time, I DO want the package in home:aljex, so I used "osc linkpac" to put a link in home:aljex without branching or copying again. That worked fine.

osc linkpac home:aljex:branches:utilities byobu home:aljex
Sending meta data...
Done.
Creating _link... Done.

That's probably not a bad way to leave it for good, but I would like to know why none of the delete commands worked as advertised.

--
bkw
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups