Mailinglist Archive: opensuse-buildservice (166 mails)

< Previous Next >
[opensuse-buildservice] Re: Failing to boot strap glibc for ARM on KVM workers (solved)
  • From: "Dominig ar Foll (Intel OTC)" <dominig.arfoll@xxxxxxxxx>
  • Date: Wed, 21 May 2014 20:57:47 +0200
  • Message-id: <537CF72B.2020604@fridu.net>
Hello

For information as it might help others.
This is how our problem was solved.

Thanks

Dominig

---------- Forwarded message ----------
From:*Stéphane Desneux*<stephane.desneux@xxxxxxxxxxxxxxxxxxx>
Date: 2014-05-21 17:03 GMT+02:00
Subject: Re: Tizen 3.0 common build break
To: "Zhang, Qiang Z" <qiang.z.zhang@xxxxxxxxx>,


Hi all,

Many thanks Qiang for the hint. It seems to solve the problem (at least
on glibc).

In the project config, I just replaced the following lines:

%ifarch armv7l
Preinstall: qemu-accel-armv7l
Runscripts: qemu-accel-armv7l
Preinstall: util-linux libmount libblkid libuuid
%endif

by:

%ifarch armv7l
Preinstall: qemu-accel-armv7l-cross-arm
Runscripts: qemu-accel-armv7l-cross-arm
Preinstall: libmount libblkid libuuid
%endif

Could you please help me to have a clean project config for Tizen:Common
by reviewing it, in particular for arm cross build ?

I'll trigger a full rebuild at some point to make sure that everything
is ok, depending on your findings.

Thanks again for your help.
--
Stéphane Desneux
Intel OTC - Vannes/FR
gpg:1CA35726/DFA9B0232EF80493AF2891FA24E3A2841CA35726

On 21/05/2014 15:56, Zhang, Qiang Z wrote:
> Hi all,
>

Dominig ar Foll
Senior Software Architect
Open Source Technology Centre
Intel SSG

Le 21/05/2014 11:03, Dominig ar Foll (Intel OTC) a écrit :
Hello,

In the Tizen project are facing some difficulties in re-boot strapping Tizen3 Common for ARM.
We did an initial bootstrap using Tizen2 Mobile (a legacy Tizen 2 ARM based and that has allowed us to build almost all Tizen3 Common packages (only 8 out of 738 are still not building).

But now in order to get a clean built, we want to self-re-bootstrap the ARMrepoand we are facing difficulties with glibcand a few other packages.
We would need help to fix the glibc build issue first as we expect that the same fix will work for the other packages.
Our configuration uses OBS workers with KVM.

Our build issue can be seen here:
https://build.tizen.org/package/live_build_log?arch=armv7l&package=glibc&project=Tizen%3ACommon&repository=arm-wayland <https://build.tizen.org/package/live_build_log?arch=armv7l&package=glibc&project=Tizen%3ACommon&repository=arm-wayland>

The error is very strange:
/home/abuild/rpmbuild/BUILD/glibc-2.18/cc-base/iconv/iconvconfig: error while loading shared libraries: /home/abuild/rpmbuild/BUILD/glibc-2.18/cc-base/iconv/iconvconfig: failed to map segment from shared object: Operation not permitted

We think that the error is due to a package that is missing in a alternative architecture (e.g. IA32) during the boot strap process and the sharelib load fails due to the Arch mismatch but we might be wrong.
We have no clue on how to correct the issue.

Do you have any idea how to remove that lock ?
Does someone know how to bootstrap ARM on an OBS with KVM workers ?

Thanks in advance for your help.


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >