Mailinglist Archive: opensuse-buildservice (166 mails)

< Previous Next >
Re: [opensuse-buildservice] Still "bad config" states in schedulers after update to 2.5
Hi Adrian,

On Fri, 09 May 2014 08:58:08 +0200
"Adrian Schröter" <adrian@xxxxxxx> wrote:

On Donnerstag, 8. Mai 2014, 14:14:43 wrote Stefan Botter:
Hi all,

I followed the advise in github #620 to update from 2.4.6 to 2.5, as
the underlying problem with the partial read of the upstream
project/repo configuration should have been fixed.

Unfortunately I still see the same symptoms, from time to time the
repo has the scheduler state "The repository setup is broken, build
not possible", accompanied with the "bad config" message in the
scheduler log, mostly for an "openSUSE.org:openSUSE:*:Update" repo.

How can I help debugging this problem?

First step would be to request the config for your repo using osc

osc buildconfig $YOUR_RPROJECT $REPO

Does it deliver a valid one?

I cannot tell right now, as all repos are in good shape ATM.

does an

obs_admin --deep-check-project ...

help?

This of course helps. Or you submit a change to a package in the repo.

There has been a discussion about that on IRC back in March, which led
to Issue #620. And the general consensus was, that the underlying
problem was already fixed in 2.5 - which it is not, if you ask me ;-)

I circumvent the problem by having a cron job running every hour
checking the scheduler logs for "bad config" and running the obs_admin
command on the repos.
But this should not be necessary, either this is a fixable problem, or
else the scheduler, who detects the problem with a repo, should try to
cure this itself, instead of leaving the repo broken without ever
thinking about it again.

Greetings,

Stefan
--
Stefan Botter
Network Manager

Jacobs University Bremen gGmbH
Campus Ring 1 | 28759 Bremen | Germany

Commercial registry: Amtsgericht Bremen, HRB 18117
CEO / Geschäftsführerin: Prof. Dr.-Ing. Katja Windt
Chair Board of Governors: Prof. Dr. Karin Lochte

< Previous Next >