Mailinglist Archive: opensuse-buildservice (83 mails)

< Previous Next >
Re: [opensuse-buildservice] Determining what's needed
op 19-04-14 17:59, Jan Engelhardt schreef:

On Saturday 2014-04-19 17:06, Koenraad Lelong wrote:

By chance I saw the output of the configure. The result of that is not what I
expected and not what I get on my own PC. On my PC configure activates a number
of interfaces :
OpenOCD configuration summary
--------------------------------------------------
MPSSE mode of FTDI based devices yes (auto)

OBS does not activate any interface :
[ 42s] OpenOCD configuration summary
[ 42s] --------------------------------------------------
[ 42s] MPSSE mode of FTDI based devices no

So I'm wondering why. Any idea's ?

Well, what check does OCD do to determine whether or not to build that?


As far as I remember I did have to add this to the spec-file, and installed those packages :
BuildRequires: libusb-1_0-devel
BuildRequires: libusb-compat-devel

Before I did that, I had the same problem.

I added the run-time-libraries (installed on my machine) to the spec-file :
BuildRequires: libusb-1_0-0
BuildRequires: libusb-0_1-4

And I ran the build again. Now I checked the log more carefully :
[ 38s] checking for LIBUSB1... no
[ 38s] configure: WARNING: libusb-1.x not found, trying legacy libusb-0.1 as a fallback; consider installing libusb-1.x instead
[ 38s] checking for LIBUSB0... no

Any idea why it doesn't find libusb ?

Koenraad

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups