Mailinglist Archive: opensuse-buildservice (83 mails)

< Previous Next >
[opensuse-buildservice] OSC configure fails on every package
Hi together,

I have a problem with osc on openSUSE 13.1 x86_64.

When I do a localbuild (f. e. osc build openSUSE_xx.x xARCH) it fails
everytime with the same error message when configure is running.
Packages without configure are building fine. I think something with
the changeroot is broken, but I don't know howto find the problem.
ALso a manual

osc chroot

doesn't work. Only when I add the Version parameter.

osc chroot openSUSE_xx.x


error:
---
[ 1s] ./configure: line 27: /dev/null: Permission denied
[ 1s] ./configure: line 72: /dev/null: Permission denied
[ 1s] ./configure: line 53: /dev/null: Permission denied
[ 1s] ./configure: line 81: /dev/null: Permission denied
[ 1s] ./configure: line 120: /dev/null: Permission denied
[ 1s] ./configure: line 135: /dev/null: Permission denied
[ 1s] ./configure: line 286: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 227: /dev/null: Permission denied
[ 1s] ./configure: line 286: /dev/null: Permission denied
[ 1s] ./configure: This script requires a shell more modern than all
[ 1s] ./configure: the shells that I found on your system.
[ 1s] ./configure: Please tell bug-autoconf@xxxxxxx and
jaris@xxxxxxxxxx
[ 1s] ./configure: about your system, including any error possibly
output
[ 1s] ./configure: before this message. Then install a modern shell,
or
[ 1s] ./configure: manually run the script under such a shell if you
do
[ 1s] ./configure: have one.
[ 1s] error: Bad exit status from /var/tmp/rpm-tmp.FkdZDC (%build)
---


Information:
Host: openSUSE 13.1 x86_64
osc: 0.144 (tested version from 12.3 and Project openSUSE:Tools)
autoconf: 8.1.2

I've mounted a tmpfs on /var/tmp/build-root/ with 4G because my ssd is
hanging completly if much I/O operations are running at the same time.

$HOME/.oscrc:
---
[general]
apiurl = https://api.opensuse.org
build-jobs = 5
use_keyring = 0


[https://api.opensuse.org]
user=seilerphilipp
passx=XXXXXXXX

[some more apis]
[...]
---

On google I dont found anything regarding this specific osc/chroot
error.

Any ideas?

Kind Regards,

Philipp



--
Philipp Seiler
Linux Consultant
Tel.: +49-175 2958714
Mail: seiler@xxxxxxxxxxxxx GPG Key: 0x75911461

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
< Previous Next >
Follow Ups