Mailinglist Archive: opensuse-buildservice (83 mails)

< Previous Next >
Re: [opensuse-buildservice] Build time dependency resolution (multiple version support)
On Mittwoch, 2. April 2014, 15:18:54 wrote Andrew Davidoff:
On Mon, Mar 31, 2014 at 2:40 PM, Dmitriy Perlow <dap@xxxxxxx> wrote:
Hello!

You completely right. Usually such packages have different names: see
allegro packages at games f.e.:
https://build.opensuse.org/package/binaries/games/allegro?repository=openSUSE_13.1
https://build.opensuse.org/package/binaries/games/allegro5?repository=openSUSE_13.1
https://build.opensuse.org/package/binaries/games/allegro52?repository=openSUSE_13.1

Thanks Dmitriy. This may be too much administrative overhead for me,
but I'll have to think more about it.

Are there plans to support multiple versions for build time
dependencies?

This conflicts a bit with the requirement to be able to downgrade rpms again in
upper layers
in case of problems.

And since this problem exists only when the packages are not prepared for
parallel installation it is a problem which would also exist on the
end-user system. He would run also into problems installing both
packages or even worse one package would corrupt the other one.
With the result of hard to debug errors...

If not, short of reading through bs_sched and related
code, is there a specific area in the codebase I'd look at if I wanted
to modify this behavior?

Thanks again.
Andy


--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE LINUX GmbH, GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 21284
(AG Nürnberg)
Maxfeldstraße 5
90409 Nürnberg
Germany



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
References